























































    
         
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content - Full Width" />
  
    <meta name="oid" content="5853633" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=55f837c4d58ee2aac783eb7feecc8233" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=55f837c4d58ee2aac783eb7feecc8233" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=55f837c4d58ee2aac783eb7feecc8233" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=55f837c4d58ee2aac783eb7feecc8233" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/kanji-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Whole Site" href="https://www.metrotimes.com/detroit/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Music Section" href="https://www.metrotimes.com/detroit/Rss.xml?oid=2124980" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Local Music" href="https://www.metrotimes.com/detroit/Rss.xml?oid=2135218" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Comments on To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena" href="https://www.metrotimes.com/detroit/Rss.xml?id=comments&amp;oid=5853633" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    <script>
      if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
    </script>
    
    
    
    <script src="/foundation/scripts/common.js?cb=d0ea999a25493885343fd93728571199"></script>
  
    
    
    
    
    <script>
      if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
    </script>
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=d0ea999a25493885343fd93728571199"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.metrotimes.com\/detroit\/Profile", "https:\/\/posting.metrotimes.com\/detroit\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="368071155345-fr5a01rd2lpbd03le6ivqgfnbb1jmfak.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->

<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />
<!-- End google fonts -->

<!-- Google Verification -->   
<script type="text/javascript" src="https://www.google.com/jsapi?key=ABQIAAAAtqeztvH8NEF24UuVX_R6nBQLskUi0KWLKDoC09NTum5Tpi1QMRQqbHK1yVFxKdfvbU15YPVeoQUgEA"></script>
<!-- End Google Verification -->

<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>

<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-643668-1', 'metrotimes.com');
    ga('send', 'pageview', { 'dimension1': 'music', 'dimension2': 'music' });
    </script>
  
  <!-- End Google Analytics -->
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="To understand Kid Rock&rsquo;s politics, we attempted to go to all six of his shows at Little Caesars Arena | Local Music | Detroit Metro Times" />
  <meta name="description" content="Senator Kid Rock?" />
  <meta name="keywords" content="kid rock, little caesars arena, Kid Rock for Senate, News, Blog, Culture, Dining, Events" />
  <title>To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena | Local Music | Detroit Metro Times</title>

  
  
  
    <meta name="author" content="Jerilyn Jordan">
  

  
  
  <meta name="news_keywords" content="kid rock, little caesars arena, kid rock for senate, news, blog, culture, dining, events" />

  
  
  
    <link rel="image_src" href="https://media2.fdncms.com/metrotimes/imager/u/slideshow/5853854/screen_shot_2017-09-26_at_11.31.35_am.png" />
    <meta name="thumbnail" content="https://media2.fdncms.com/metrotimes/imager/u/slideshow/5853854/screen_shot_2017-09-26_at_11.31.35_am.png" />
  

  
    
      <link rel="canonical" href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633&media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" />
    
  

  
    <meta property="fb:app_id" content="310950202407744" />
  

  
  <meta property="og:site_name" content="Detroit Metro Times" />
  <meta property="og:title" content="To understand Kid Rock&rsquo;s politics, we attempted to go to all six of his shows at Little Caesars Arena" />
 
  
    <meta property="og:image" content="https://media2.fdncms.com/metrotimes/imager/u/slideshow/5853854/screen_shot_2017-09-26_at_11.31.35_am.png" />

    
    

    
    

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="304" />
    
  

  
  
    <meta property="og:description" content="Senator Kid Rock?" />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/metrotimes/imager/u/slideshow/5853854/screen_shot_2017-09-26_at_11.31.35_am.png">

    
    

    
      <meta name="twitter:creator" content="@JerilynJordanC">
    

    <meta name="twitter:site" content="">
    <meta name="twitter:title" content="To understand Kid Rock&rsquo;s politics, we attempted to go to all six of his shows at Little Caesars Arena">
    <meta name="twitter:description" content="Senator Kid Rock?">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">5853633</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170928175108</Attribute>
        <Attribute name="creationdate">20170926111125</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20170927010000</Attribute>
            <Attribute name="releasedate">20170927</Attribute>
            <Attribute name="releaseepoch">1506488400</Attribute>
            <Attribute name="title">To understand Kid Rock&#x2019;s politics, we attempted to go to all six of his shows at Little Caesars Arena</Attribute>
            <Attribute name="author">3983126</Attribute>
            <Attribute name="authorname">Jerilyn Jordan</Attribute>
            <Attribute name="authorsortname">Jordan, Jerilyn</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.metrotimes.com\/detroit\/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena\/Content?oid=5853633"
          },
          "headline": "To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena",
          
            "description": "Let me be clear: This is not a matter of taste. \"You should be vaccinated,\" a friend warned.",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/metrotimes\/imager\/u\/original\/5853854\/screen_shot_2017-09-26_at_11.31.35_am.png",
              "width": 1067,
              "height": 540,
              "@type": "ImageObject"
            },
          
          "datePublished": "2017-09-27T01:00:00",
          "dateModified": "2017-09-28T17:51:08",
          
            "author": {
              "name": "Jerilyn Jordan",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Detroit Metro Times",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.metrotimes.com\/imager\/b\/google-amp-logo\/808579\/8e1e\/MT_Redbkgd.png",
                "width": 501,
                "height": 501,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Content" class="ContentFullWidth Kanji10Zone LocalMusic music">




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PHZV5V"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PHZV5V');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="AdInterstitial" class="Leader ContentFullWidth ">
  <!-- /43707298/DET_DesktopInterstitial -->
          <div id="div-gpt-ad-det_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/DET_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_desktopinterstitial');
                  });
              </script>
          </div>
</div>
</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentFullWidth " style="display:none">
        
        
          Switch to the <a href="https://m.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  











<div id="LogoHeader" class="GlobalHeader ContentFullWidth ">
  
    
    <div id="logoLeft">      
      <a href="https://www.metrotimes.com/" title="Detroit Metro Times">Detroit Metro Times</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/DET_728x90 -->
          <div id="div-gpt-ad-det_728x90-1" style="" data-content-type="ad" data-slot="/43707298/DET_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_728x90-1');
                  });
              </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->
















  <div id="NavigationHorizontal" class="GlobalHeader ContentFullWidth ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_News">
          <a href="https://www.metrotimes.com/detroit/news-and-views/Section?oid=2135207"  class="subnav_link" id="SNAVL_News">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ArtsCulture">
          <a href="https://www.metrotimes.com/detroit/arts-and-culture/Section?oid=2124977"  >Arts &amp; Culture</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_FoodDrink">
          <a href="https://www.metrotimes.com/detroit/food-and-drink/Section?oid=2124982"  >Food &amp; Drink</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_Music">
          <a href="https://www.metrotimes.com/detroit/music/Section?oid=2124980"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Slideshows">
          <a href="http://photos.metrotimes.com"  >Slideshows</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Calendar">
          <a href="https://www.metrotimes.com/detroit/EventSearch"  >Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_BestOf">
          <a href="https://www.metrotimes.com/detroit/BestOf"  >Best Of</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Giveaways">
          <a href="https://www.metrotimes.com/detroit/FreeStuff"  >Giveaways</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Subscribe">
          <a href="https://www.metrotimes.com/detroit/NewsletterSignup/Page"  >Subscribe</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_News" style="display:none;">
          

          

          <li class="">
            <a href="https://www.metrotimes.com/detroit/IssueArchives?issue=this%20week"  title="">e-Edition</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.metrotimes.com/detroit/joblistings/Page"  title="">Local Job Listings</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="AdPencilBar" class="GlobalHeader ContentFullWidth ">
  <!-- /43707298/DET_970x90 -->
          <div id="div-gpt-ad-det_970x90" style="" data-content-type="ad" data-slot="/43707298/DET_970x90" data-output="asynchronous" data-width="970" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_970x90');
                  });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">
    <!-- ZoneA -->
    <div id="gridTopRow">
      



  
    <div id="StoryBreadcrumb" class="HomeTopRow ContentFullWidth ">
      <p class="issueInfo">
        <span class="date">
          
            <a href="https://www.metrotimes.com/detroit/IssueArchives?issue=5853631">September 27, 2017</a>
          
        </span>

  			
          <a href="https://www.metrotimes.com/detroit/music/Section?oid=2124980">Music</a>
        
        
          &raquo; <a href="https://www.metrotimes.com/detroit/ArticleArchives?category=2135218">Local Music</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  





  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: https://www.metrotimes.com
    var.publicDesktopServer = https://www.metrotimes.com
    var.shareUrl = https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633
    s/https\:\/\/www\.metrotimes\.com/https\:\/\/www\.metrotimes\.com/
    var.shareUrl = https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633
  -->




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="HomeTopRow ContentFullWidth ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content%3Foid%3D5853633&text=To%20understand%20Kid%20Rock%E2%80%99s%20politics%2C%20we%20attempted%20to%20go%20to%20all%20six%20of%20his%20shows%20at%20Little%20Caesars%20Arena" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.metrotimes.com/detroit/Tools/EmailFriend?oid=5853633" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?mode=print&amp;oid=5853633" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-51f9437a2abb7e86" addthis:url="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" addthis:title="To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena" addthis:description="Senator Kid Rock?" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51f9437a2abb7e86", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




  

  

  
    <div id="StoryHeader" class="HomeTopRow ContentFullWidth  home_feature_section_feature">
      <div class="storyHead">
        <h1 class="headline headline-5853633">To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena&nbsp;</h1>        
        
          <h2 class="subheadline">Senator Kid Rock?</h2>
        
        
          

          <cite class="byline">
            <span class="byAttribute">By</span> <a href="https://www.metrotimes.com/detroit/ArticleArchives?author=3983126" rel="author">Jerilyn Jordan</a>
              
              
                
                  
                    <span class="twitter"><a href="https://twitter.com/JerilynJordanC" title="JerilynJordanC" target="_blank">@JerilynJordanC</a></span>
               
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  








  
  
  
  
  
  
  
    

    
      <div id="MagnumImage" class="HomeTopRow ContentFullWidth ">
        <div class="magnumContainer">
          

          
          
          
          
          
            
          

          
          
          

          
          

          
          
            <span class="clicktozoom">click to enlarge</span>
            <a href="https://media2.fdncms.com/metrotimes/imager/u/original/5853632/gettyimages-846259862_master.jpg" class="zoomable"><img src="https://media2.fdncms.com/metrotimes/imager/u/blog/5853632/gettyimages-846259862_master.jpg" width="980" height="700" class="magnum" alt="Political speech or performance art? Kid Rock gets behind the podium during one of his shows opening Detroit&rsquo;s new Little Caesars Arena." /></a>
          
          
          
            
            
              
                
                  
                    <p class="credit"><a href="https://www.metrotimes.com/detroit/ImageArchives?oid=5853632">Getty Images</a></p>
                  
                
              
            
              
                
                  <p class="caption">Political speech or performance art? Kid Rock gets behind the podium during one of his shows opening Detroit’s new Little Caesars Arena.</p>
                
              
            
          
        </div>
      </div>
    
    
    
    
  






<div id="StoryLayoutFullWidth" class="HomeTopRow ContentFullWidth  home_feature section_feature">

  

    

    













    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      
        
        
      
        
        
          
        
        
        
        

        
      
      
      
      
    
      <div id="storyBody" class="page1 home_feature section_feature">
        
      
        

        
        
          <script>
          dnLoadScript("https://platform.twitter.com/widgets.js", true);
        </script>
        
          
          
        
        
        <p>
        Let me be clear: This is not a matter of taste.  
</p>
            
            
          
            
              
      
<p>
        "You should be vaccinated," a friend warned. "You should be institutionalized," suggested another. "Why the fuck would you do this again?" my father asked. It was a reasonable question. After all, this wasn't my first rodeo — but for the love of God was I hoping it would be my last.  
</p>
            
            
          
            
              
      
<p>
        Two years ago, I described walking into my first Kid Rock show as feeling like a disoriented and wounded gazelle staggering into the lion's den. I planned to attend all 10 of Kid Rock's shows at DTE Energy Music Theatre — a sort of travel diary from the heart of American kitsch. But I was without the support of a publication or an editor; the piece ultimately went unpublished, and I had little to no faith that what I was doing at the time meant anything. To this day, I remain unconvinced.  
</p>
            
            
              <div class="inlineComponent inlineCenter">
                <div id="AdNativeInline" class="HomeTopRow AdNativeInline ">
  <!-- /43707298/DET_DesktopNative -->
          <div id="div-gpt-ad-det_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/DET_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_desktopnative-2');
                  });
              </script>
          </div>
</div>
              </div>
            
          
            
              
      
<p>
        I promised myself that I would never endure another Kid Rock concert again. (Especially after I was urinated on in the cheap lawn seats. Don't ask.)  
</p>
            
            
          
            
              
      
<p>
        A lot can change in two years.  
</p>
            
            
          
            
              
      
<p>
        On July 12, a mysterious website <a href="http://kidrockforsenate.com" target="_blank">kidrockforsenate.com</a> surfaced. Kid Rock took to Twitter to confirm that the site was in fact real, and teased a major announcement in the "near future." The site — featuring a portrait of the stoic rocker perched beside a taxidermic deer, with the caption "Are You Scared?" — offered apparent campaign merchandise, ranging from T-shirts to lawn signs, donning a red, white, and blue "Kid Rock '18 for U.S. Senate."  
</p>
            
            
          
            
              
      
<p>
        Was he serious? On the one hand, we live in a country with a President Donald Trump. (Kid Rock was a staunch supporter, <a href="/the-scene/archives/2016/12/05/kid-rock-embarrasses-himself-with-a-line-of-trump-themed-merchandise" target="_blank">selling pro-Trump merch</a> in 2016. He was later <a href="/city-slang/archives/2017/04/20/kid-rock-ted-nugent-and-sarah-palin-visited-trump-in-the-white-house" target="_blank">invited to the White House.</a>)  
</p>
            
            
              <div class="inlineComponent inlineRight">
                <div id="AdMediumRectangle1300x250" class="HomeTopRow AdMediumRectangle1300x250 ">
  <!-- /43707298/DET_300x250 -->
          <div id="div-gpt-ad-det_300x250-1" style="" data-content-type="ad" data-slot="/43707298/DET_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_300x250-1');
                  });
              </script>
          </div>
</div>
              </div>
            
          
            
              
      
<p>
        But by August, the entire national mood somehow got even more surreal and paranoid. In Charlottesville, Virginia, a clash over the removal of a Confederate monument <a href="https://www.nytimes.com/2017/08/13/us/charlottesville-virginia-overview.html?mcubz=1" target="_blank">turned deadly</a> when a white supremacist drove his car into a crowd of protesters, and the nation's racist underbelly of neo-Nazis, Klansmen, and the alt-right were not only made visible but seemingly were emboldened.  
</p>
            
            
          
            
              
      
<p>
        When the <a href="/news-hits/archives/2017/08/12/red-wings-logo-appropriated-by-white-supremacists-team-vows-to-explore-every-possible-legal-action" target="_blank">Detroit Red Wings' logo appeared</a> as an alt-right insignia in Charlottesville, the team was quick to issue a statement denouncing its use by hate groups. But online commentators were quick to point out an apparent double standard: Kid Rock — who had <a href="/city-slang/archives/2017/08/15/kid-rock-and-the-confederate-flag-a-history" target="_blank">previously drawn criticism for performing with a Confederate flag</a> — was opening the team's new taxpayer-subsidized Little Caesars Arena the next month with a string of six dates.  
</p>
            
            
          
            
              
      
<p>
        Soon there were calls to protest. "Kid Rock is a disgrace. Why is he first act of Little Caesars Arena?" <i></i><a href="http://www.bridgemi.com/guest-commentary/kid-rock-disgrace-why-he-first-act-little-caesars-arena" target="_blank"><i>Bridge</i> magazine asked</a>. "Having Kid Rock open this arena is erecting a sturdy middle finger to Detroiters — nothing less," <a href="http://www.freep.com/story/opinion/columnists/stephen-henderson/2017/09/02/kid-rock-caesars-ilitch-arena/623154001/" target="_blank">wrote the <i>Free Press</i>' Stephen Henderson</a>. "Kid Rock is the musical icon of the white supremacy movement," National Action Network political director <a href="http://www.fox2detroit.com/news/local-news/sam-riddle-fires-back-at-kid-rock-ahead-of-detroit-concert-protests" target="_blank">Sam Riddle told Fox 2</a>.  
</p>
            
            
          
            
              
      
<p>
        On Sept. 11, the day before his Little Caesars Arena christening, Rock issued <a href="https://kidrock.com/blog/blog/448964/people-pay-no-attention-to-the-garbage-the-extreme" target="_blank">a defensive, rambling rant</a>, calling out the <i>Free Press</i>, fake news (while also falsely claiming he had sold out his six shows in January), national anthem kneelers (he has uttered "fuck Colin Kaepernick" onstage), and "piece of shit criminal" Riddle, and then ending with an unintentionally comic post-script: "P.P.P.P.P.S. I LOVE BLACK PEOPLE!!" (He also maintained he was still merely "thinking of running for office." Watchdog groups have pointed out <a href="http://www.mlive.com/news/index.ssf/2017/09/group_alleges_kid_rock_violati.html" target="_blank">he could be fined</a> for breaking campaign finance law by failing to properly register.)  
</p>
            
            
          
            
              
      
<p>
        In one final act of pettiness, Rock's camp <a href="http://www.freep.com/story/news/local/michigan/detroit/2017/09/12/kid-rock-detroit-free-press-credentials-lca-concert/657462001/" target="_blank">denied the <i>Free Press</i>'</a> and <i>Metro Times</i>' media credentials without as much as a copied and paste rejection. But that didn't matter. We bought tickets to all six shows.  
</p>
            
            
          
            
              
      
<p>
        The hope was that by the end of this masochistic marathon, we'd have an answer to whether Kid Rock was really running for Senate, and to maybe understand the politics of potential Kid Rock voters. If we're at all lucky, the answer will not be the least bit entertaining.  
</p>
            
            
          
            
              
     <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media2.fdncms.com/metrotimes/imager/u/blog/5853971/74020019.jpg?cb=1506635468" width="980" height="650" alt="Protesters take to the street before the first of Kid Rock&rsquo;s six shows at Little Caesars Arena. - JERILYN JORDAN" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Jerilyn Jordan                                          </li>                                                                                                                            <li class="imageCaption">                      Protesters take to the street before the first of Kid Rock’s six shows at Little Caesars Arena.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        <b>Day 1: Both sides now</b>  
</p>
            
            
          
            
              
      
<p>
        It was hard to believe this would be my 11th Kid Rock show in two years. By this time, I had seen Kid Rock perform more than any of my favorite bands. I mean, I've only seen Radiohead twice. Twice!  
</p>
            
            
          
            
              
      
<p>
        The first of the shows was met with a protest, organized by the National Action Network. A group of some 200 march from Grand Circus Park up Woodward Avenue, chanting "No justice, no pizza." I follow them along the curb, balancing in an attempt to blur my role as participant and spectator.  
</p>
            
            
          
            
              
      
<p>
        "Go home! No one wants you here!" a gaggle of impassioned Kid Rock fans shout from Hockeytown Cafe's rooftop bar, apparently both pre-gaming and lazily counterprotesting.  
</p>
            
            
          
            
              
      
<p>
        "What are they even protesting anyway?" a woman says as she followed the march with her cell phone. "Who cares?"  
</p>
            
            
          
            
              
      
<p>
        "Kid Rock is a traitor to this city, don't you get it?" a guy in a blue button-up says, putting his face much too close to my face as I trip slightly on the QLine tracks.  
</p>
            
            
          
            
              
      
<p>
        Once in front of the arena, we are asked to take a knee as a man with a megaphone sang a shaky version of the national anthem.  
</p>
            
            
          
            
              
      
<p>
        The march loops in front of the arena and made it's way south, back toward where we started. I trail slightly behind as I mapped the perfect moment to slip into character and into the very event I was protesting.  
</p>
            
            
          
            
              
     <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/metrotimes/imager/u/original/5853972/img_9475.jpg" class="zoomable" rel="contentImg_gal-5853633" title="JERILYN JORDAN">                  <img src="https://media1.fdncms.com/metrotimes/imager/u/blog/5853972/img_9475.jpg?cb=1506459194" width="250" height="333" alt="JERILYN JORDAN" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Jerilyn Jordan                                          </li>                                                                                                                                                                                      </ul>                                                       </div>  
<p>
        Before I can slip away, a steady stream of motorcycles barreled down Woodward. It was a parade of leather-clad bikers — Bikers Against Radical Islam, Bikers for Trump, the Detroit Highwaymen, and others — counterprotesters revving their engines in intimidation.  
</p>
            
            
          
            
              
      
<p>
        For the first time during the protest, I'm uneasy. Threats of violence seemed unavoidable as an antagonizing tweet went viral just hours earlier: "You wanna block traffic? Get run over. Your choice." Based on the recent events in Charlottesville, there was plenty of reason to worry.  
</p>
            
            
          
            
              
      
<p>
        It was time to get this show on the road.  
</p>
            
            
          
            
              
      
<p>
        Once inside, I'm greeted by a wall of smiling greeters passing out handfuls of miniature American flags. "God bless America, and enjoy the show!" they say as I take a flag. A curious start.  
</p>
            
            
          
            
              
      
<p>
        Upon entry, I needed to pick up my will call ticket. An LCA staffer leads the way, guiding me through the growing crowd. While we walk, the LCA staffer asks about the protest outside. "What were they protesting?" she asks. She seems to not have heard anything about it, despite the fact that it got plenty of media coverage in the weeks and days before.  
</p>
            
            
          
            
              
      
<p>
        I tell her it was about Black Lives Matter. "Oh, that's bullshit," the staffer says. "I think it's being fed by the media and people are buying into it way too much."  
</p>
            
            
          
            
              
      
<p>
        She continues guiding us through the arena's main concourse. "I've worked in Detroit for years and there's never been this much racism," she says. "Everyone is so angry."  
</p>
            
            
          
            
              
      
<p>
        In it's official statement to the Kid Rock backlash, Little Caesars Arena downplayed Rock's politics as just those of one of many performers. "Kid Rock has been a consistent supporter of Detroit, and the marketplace has responded accordingly to his appearances," the statement said. "Performing artists' viewpoints in no way represent an endorsement of those viewpoints by Olympia Entertainment."  
</p>
            
            
          
            
              
      
<p>
        This would be an easily digestible point if it was a one-off concert, instead of six. However, Kid Rock isn't just a performer at Little Caesars Arena. He is also something of a partner. The venue hosts Kid Rock's Made in Detroit restaurant, where I decide to start my night with Kid Rock's very own Badass Beer.  
</p>
            
            
              <div class="inlineComponent inlineRight">
                <div id="AdMediumRectangle2300x250" class="HomeTopRow AdMediumRectangle2300x250 ">
  <!-- /43707298/DET_300x250 -->
          <div id="div-gpt-ad-det_300x250-2" style="" data-content-type="ad" data-slot="/43707298/DET_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_300x250-2');
                  });
              </script>
          </div>
</div>
              </div>
            
          
            
              
      
<p>
        Suddenly, a crowd appears on the street in front of the restaurant. It's the counterprotesters — dozens of leather-clad bikers chanting "USA! USA!" One waves a Kid Rock "Made in Detroit" flag alongside others wielding American flags — as if both were equal emblems of patriotism.  
</p>
            
            
          
            
              
      
<p>
        It seems that by the time the counterprotesters parked their motorcycles, the original protest group had dispersed. It's hard not to feel as though a potentially violent clash was narrowly avoided — by mere minutes.  
</p>
            
            
          
            
              
      
<p>
        I return to my Badass Beer transaction. While waiting, I encounter a woman who is excited for her sixth Kid Rock show, and just as excited to be the first crowd to ever grace Little Caesars Arena. "It's special," she says.  
</p>
            
            
          
            
              
      
<p>
        When asked if the protest got in the way of her being able to get in early, she wasn't even aware that there was a protest. "What were they protesting?" she asks. I shrug and tell her a condensed, one-sentence version. "Oh," she says, shaking her head as if the idea of anyone being upset would tarnish her vibes. She doesn't get it. This seems to be a recurring theme among the people I talk to.  
</p>
            
            
          
            
              
      
<p>
        "The show is going to be amazing," she says, changing the subject. "He's better now. Now he's more country rock [than] the dirty, sleazy rock from before. You know, the Pam Anderson days."  
</p>
            
            
          
            
              
      
<p>
        As it turns out, my $20 seat is bad. Like, really bad. However, I have to find the beauty in my cockeyed view of the backstage area from the near-to-last row.  
</p>
            
            
          
            
              
      
<p>
        The show begins with the image of a giant projected "Fuck Tank" gauge and a long mashup of Kid Rock songs, that one Journey song, some Motown jam, and unsettling revving engine noises as the gauge's dial toggles between full and half-full, until it reaches its final resting position on empty.  
</p>
            
            
          
            
              
      
<p>
        Fittingly, Kid Rock starts his set with a literal circus — an explosion of flares and fireworks complete with a flock of Uncle Sams on stilts, a fire-breather, and a dwarf dressed as a clown.  
</p>
            
            
          
            
              
      
<p>
        "Love you when you hate us," Rock proclaims with arms spread. "Welcome to the greatest fuckin' show on Earth." Midway through, a butler presents Rock with a joint on a silver platter that he proceeds to light and smoke as he continues the song. A total rockstar move, considering LCA is a nonsmoking venue and does not offer any designated area (let alone re-entry) for smokers.  
</p>
            
            
          
            
              
      
<p>
        As the song ends, Rock bids us "goodnight" as he bows and runs off stage as the stadium goes black. "Is he coming back?" I hear someone say. "He fucking better!"  
</p>
            
            
          
            
              
     <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media1.fdncms.com/metrotimes/imager/u/blog/5853969/a911918-r1-03-20a.jpg?cb=1506635468" width="980" height="662" alt="He kind of looks like the Wizard of Oz, doesn&rsquo;t he? - JERILYN JORDAN" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Jerilyn Jordan                                          </li>                                                                                                                            <li class="imageCaption">                      He kind of looks like the Wizard of Oz, doesn’t he?                    </li>                                                                                                </ul>                                                       </div>  
<p>
        In true cliffhanger fashion, a few minutes pass before a voice erupts over the loudspeaker. "Please welcome the next senator of the great state of Michigan, Kid "motherfucking" Rock!" Rock then takes to a podium with a modified version of the presidential seal as "Hail to the Chief" plays.  
</p>
            
            
          
            
              
      
<p>
        He then gives a quasi-rhyming "stump speech," seemingly made up entirely of vague statements built around buzzwords gleaned from Fox News. Each couplet is punctuated by a guitar and drum blast — and elicits an eruption of applause from the some 20,000 fans.  
</p>
            
            
          
            
              
      
<p>
        What it lacks in substance, it makes up for in context, and is worth sharing in its entirety:  
</p>
            
            
          
            
              
      
<blockquote>
           
  <p>
              <i>What's going on in the world today? It seems the government wants to give everyone health insurance, but wants us all to pay.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>And to be very frank, I really don't have a problem with that, since God has blessed me and made my pockets fat.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>But a redistribution of wealth seems more like their plan. And I don't believe you should save, sacrifice, do things by the book, and then have to take care of some deadbeat, milking the system, lazy ass motherfucking man.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>Now, the issue of struggling single parents is an issue close to my heart. But read my lips: We should not reward those who can't even take care of themselves but keep having kid after fucking kid.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>Of course, we should help them out. I don't want to stand here and sound like a jerk. But let's help 'em out with child care, job training, and find them a fucking place to work.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>And you deadbeat dads, who refuse to be a man, who refuse to be there for your sons, to raise them up to be good men? You no-good derelict sperm donor wannabes? I say lock all you assholes up and throw away the fucking keys.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>And if you want to take a knee, or sit during our "Star-Spangled Banner," call me a racist, because I'm not PC, and think you have to remind me that black lives matter.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>Nazis. Fucking bigots. And now again the KKK? I say fuck all you racists. Stay the hell away.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>And why these days, is everything sooooo gay? Gay rights, transgender this and that. I say let gay folks get married if they want, and I'm not even close to a death trap.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>But things shouldn't be this complicated and, no, you don't get to choose. Because whatever you have between your legs should determine the bathroom that you use.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>It's no secret we're violent, and we all should take some blame. We should be ashamed, because we all seem scared to call Him by His name.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>So please, almighty Jesus, if you're looking down tonight, please guide us with your wisdom, and give us strength to fight. To fight the tyrant evils, that lurk here and abroad, and remind us all we are still just one nation under God.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>And I do believe it to be self-evident, that we're all created equal. I said it once, I'll scream it again: I love black people. And I love white people, too. But neither as much as I love red, white, and blue.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>If Kid Rock for Senate has got some folks in disarray, wait 'til they hear Kid Rock for president of the U.S.A.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>Wouldn't that be a sight to see? Kid Rock in Washington, D.C.? Standing on the desk of the Oval Office like a G. Holdin' my dick ready to address the whole country.</i>      
  </p>
            
            
          
            
              
          
  <p>
              <i>We'll look 'em straight in the eyes. The eyes of the nation, live on TV. And tell 'em you never met a motherfucker quite like me.</i>      
  </p>
            
            
          
            
              
   
</blockquote>
      
<p>
        And... that's it. The podium is wheeled offstage and Rock breaks into "You Never Met a Motherfucker Quite Like Me" and suddenly we are tuned, once again, into Kid Rock's confused and genre-less spectacle.  
</p>
            
            
          
            
              
      
<p>
        Turns out Rock is using his 2017 tour as an opportunity to hodgepodge all of his selves into one long montage of lowest common denominator music, bouncing between genres and their appropriate costumery — a tracksuit and ghettoblaster for his old school rap song, a fur coat for the rock song, and a leather suit embossed with crystals in the shape of flames for the Southern-revivalist track (obviously). At one point, his DJ takes a moment in the set to taunt Rock for his ever-changing styles and middle-aged softness, clicking through a slideshow of photos for demonstration. At various other points, Rock summons best friend Uncle Kracker not once but twice, and invites a backup singer to fill Sheryl Crow's spot for their 2001 ballad "Picture." And yes, the pole dancers of Rock's Pam Anderson-era yesteryear have returned, too.  
</p>
            
            
          
            
              
      
<p>
        But of all these colorful moments of contradictory glitz and grit, it is Rock's piano intro into his '99 hit "Cowboy" that was his most eyebrow-raising. While striking the keys in a bucket hat-fedora combo, he sings, "If anyone's going to protest tonight, they can protest these nuts." This prompts my row to start a modest and dim attempt at a "USA" chant. (And one single voice yelling "Trump!") Rock laughs and admits that it wasn't a nice thing to say and adds, "What a good fucking job the Detroit police did tonight, give it up for them."  
</p>
            
            
          
            
              
      
<p>
        He finishes his new take on an old intro and bursts into "Cowboy" which includes the chorus, "I can smell a pig from a mile away" — another example of Rock's confounding duality as both patriot and menace. (Like how he can both wave the Confederate flag while also criticizing national anthem kneelers.) A devil without a cause.  
</p>
            
            
          
            
              
      
<p>
        Before Rock departs and goes into his back-to-back encores, he takes a moment during night one to dish out some thank yous from a piece of paper, shouting out the "folks who built this place" — Olympia's owners, the Ilitch family; the "whole city of Detroit and its taxpayers for the investment in our great city"; and concluding, of course, with "all of you — the greatest rock 'n' roll fans in the world."  
</p>
            
            
          
            
              
      
<p>
        As we filter out into the streets, the <a href="/news-hits/archives/2017/09/16/vandals-nearly-destroy-trump-unity-bridge-ahead-of-pro-trump-rally-in-washington" target="_blank">Trump Unity Bridge</a> — a mobile shrine to Trump, which has recently been amended to now feature Kid Rock's name — rolls by and fans riotously cheer. I stand still, for a moment, as I did earlier with the motorcycles, this time my hands over my face. It was all happening... or was it?  
</p>
            
            
          
            
              
      
<p>
        One down. Five to go.
</p>
            
            
          
            
              
  


        <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media2.fdncms.com/metrotimes/imager/u/blog/5853974/a911918-r3-12-6a.jpg?cb=1506635468" width="980" height="662" alt="There is poetry in spending $7 on a single slice of pizza from a chain that built its empire on the $5 Hot-N-Ready. - LEE DEVITO" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Lee DeVito                                          </li>                                                                                                                            <li class="imageCaption">                      There is poetry in spending $7 on a single slice of pizza from a chain that built its empire on the $5 Hot-N-Ready.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        <b>Day 2: Between a Rock and a hard place</b>  
</p>
            
            
          
            
              
      
<p>
        It turns out I am an emotional eater. I end up spending nearly $30 on hot dogs, pretzels, and other breaded things as I counted the minutes until I could leave what I have already coined as my Pizza Pizza Prison. Underscoring the nexus of crass corporate interests at play here, I find poetry in spending $7 on a single slice of pizza (cleverly marketed as a "super slice") from a chain that built its empire on the $5 Hot-N-Ready.  
</p>
            
            
          
            
              
      
<p>
        "Two hours and thirty-five minutes of pleasure remaining," I mumble to myself as I lick spilled beer from my fingernails. It is here that I take note of an on-duty black cop who seems to be having the time of his life — or at least more fun than I was having. Drunk Kid Rock fans ask for fist bumps, photos, and even a few polite requests to be arrested, holding their wrists out, with pleas of, "I'm just too lit, officer." The officer plays along and instantly seems like someone that might be able to lift my mood. I linger a few feet away as I calculate the best entry into conversation. Lucky for me, he did all of the work.  
</p>
            
            
          
            
              
      
<p>
        "Any girl that makes Beavis and Butthead look good is alright in my book," he said, referring to my shirt, closing the gap between us. Then, a more blunt overture: "You're a sexy little thing, aren't you?"  
</p>
            
            
          
            
              
      
<p>
        While I found his introduction sort of totally gross and inappropriate, I laugh, shrug and rest my hand on his arm. "I do what I can."  
</p>
            
            
          
            
              
      
<p>
        "Are you having fun?" he asks. He insists I don't look like I'm enjoying myself, and I admit that this isn't exactly my scene. When asked if he's having fun, his face lights up.  
</p>
            
            
          
            
              
      
<p>
        "I'm making money, girl. I feel good," he says. "You know somebody asked me, 'Are you a Kid Rock Fan?' I said, 'Well, he's human, so yes, but I don't know anything about his music,'" he admits.  
</p>
            
            
          
            
              
      
<p>
        I point out that I haven't seen any black people in attendance and suggest that whether unfairly or not, Kid Rock appears to have become a poster child for white supremacy, so it makes sense as to why that may be true.  
</p>
            
            
          
            
              
      
<p>
        "No, no. I think he's just confused," the officer says. "Kids aren't born like that, you know. Racism is learned. Somewhere that person learned that attitude, so it's up to us to change that."  
</p>
            
            
          
            
              
      
<p>
        We shake hands here and swap names. I casually suggest that perhaps someone like Kid Rock is a symptom of that very issue.  
</p>
            
            
          
            
              
      
<p>
        "This is how I look at it: It's up to me to let other people know that I'm a nice guy," he explains. "I'm going to give everyone the benefit of the doubt. Every fight and argument, there's always someone who's got to step out first, right? So I'm going to step out first and say, 'Hi, how are you?' And if you've got a problem at that point then it's you with the problem."  
</p>
            
            
          
            
              
      
<p>
        He tells me that as a police officer, that is the one thing he can control.  
</p>
            
            
          
            
              
      
<p>
        "I wasn't at the protest. But the key is to say, 'Hey, I hear you and I respect your opinion,'" he says calmly, waving his hand in front of him as if smoothing the air between us. "As a sergeant, I teach my rookie officers to treat everyone with respect until they prove to deserve to be treated otherwise."  
</p>
            
            
          
            
              
      
<p>
        I stop pressing him with questions because, well, he's a police officer and I have nine unpaid parking tickets and there's at least three joints worth of loose weed in the bottom of my purse. I thank him for his service and for keeping me company... and I silently thank him for his candid ambivalence.  
</p>
            
            
          
            
              
      
<p>
        I did not think my seat could get any worse but on night two I am proven wrong and might be able to touch the ceiling if I had cared enough to stand up. Again, without any deviation from the script, Kid Rock trolls us with his own apparent <i>fake</i> news by means of the same <i>fake</i> stump speech and again, firing up thousands of <i>real</i> people who are taking him very seriously without any real promise of running (or not running) for office.  
</p>
            
            
          
            
              
      
<p>
        Is this how James Franco's character felt in that movie <i>127 Hours</i>? Cutting my own arm off would do no good here, but as I approach my perch with my own "Fuck Tank" nearly empty, I consider it.  
</p>
            
            
          
            
              
      
<p>
        On with the fucking show. All two hours of it.  
</p>
            
            
          
            
              
     <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media2.fdncms.com/metrotimes/imager/u/blog/5853967/a911918-r3-08-11a-copy.jpg?cb=1506635468" width="980" height="662" alt="Kid Rock fans. - LEE DEVITO" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Lee DeVito                                          </li>                                                                                                                            <li class="imageCaption">                      Kid Rock fans.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        <b>Day 3: Same as it ever was</b>  
</p>
            
            
          
            
              
      
<p>
        Day three feels a lot like day two in that I am hungover and totally fucking over this whole thing.  
</p>
            
            
          
            
              
      
<p>
        Considering Kid Rock's carefully constructed image as a no-fucks-given rockstar, one would assume his set would be full of surprises (especially when giving six shows in a row). The truth is, Kid Rock performs the same set, each night, verbatim. The only discernible difference is his announcement of what day of the week it is, and what show we were on. Everything else is the same, from his "is-he-or-isn't-he?" stump speech to his introduction of his underwhelming special guest Uncle Kracker.  
</p>
            
            
          
            
              
      
<p>
        In fact, he has even recycled his "spontaneous" moments from his previous tour two years ago, thus widening the gap between performer and provocateur. The words are the same. The show is the same. I'm losing hope that he is ever going to say something worth listening to. What have I signed up for?  
</p>
            
            
          
            
              
     <div class="pullQuote">
              <a href="https://twitter.com/intent/tweet?url=https%3A//www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content%3Foid%3D5853633&text=Considering+Kid+Rock%27s+image+as+a+no-fucks-given+rockstar%2C+one+would+assume+his+set+would+be+full+of+surprises.+The+truth+is%2C+Kid+Rock+performs+the+same+set%2C+each+night%2C+verbatim.">
                Considering Kid Rock's image as a no-fucks-given rockstar, one would assume his set would be full of surprises. The truth is, Kid Rock performs the same set, each night, verbatim.
                <span class="pullQuoteTwitter">click to tweet</span>
              </a>
            </div>  
<p>
        It was here, on my final lap to my seat that I encounter an enticing macaroni and cheese bar where two voices shout quite possibly my least favorite question in my general direction: "Oh my god, what high school did you go to?"  
</p>
            
            
          
            
              
      
<p>
        "We knew it!" a woman says. "You've changed so much but I knew that face." As for me, I did not remember this couple. Not even after they told me their names. But that doesn't stop me from pretending. "OMG, yes, totally you were both there... in high school."  
</p>
            
            
          
            
              
      
<p>
        Brandon and Amanda were separated by one graduating class, and though they did not know each other then, they are married now, with twins, and never left our hometown of Harrison Township (except for when Brandon was deployed during their first year of marriage). We swap our six degrees of separation, which drunkenly lead me to offer up way too much information about my ex-boyfriend and our break-up — and holy shit was I happy to talk about something other than Kid Rock.  
</p>
            
            
          
            
              
      
<p>
        "Thank you both for being... so nice to me," I say. "I was sort of a total loser in high school so this... this was nice."  
</p>
            
            
          
            
              
      
<p>
        I suddenly feel like the cool kid. After all, going to six Kid Rock shows is akin to how I felt in high school: alone, unable to relate to anyone, and, ultimately, surrounded by pizza.  
</p>
            
            
          
            
              
      
<p>
        My unexpected #FlashbackFriday moment drew me to reflect on my first 10 Kid Rock shows as I aimlessly wander through LCA. It was easier to socialize with strangers two years ago at DTE Energy Music Theatre — LCA's enclosed, casino-like layout does not lend itself to intergroup mingling. But the venue layout wasn't the only difference between then and now. I am reminded, as I bump into a man donning a Confederate flag shirt that appeared almost vintage (meaning, it had been worn... a lot) that I hadn't encountered the image much this time around.  
</p>
            
            
          
            
              
      
<p>
        During three days at LCA I have seen a total of six garments sporting the controversial image. This came as a bigger shock than the 50-plus flags I saw — per day — at DTE. People had fashioned capes, bucket hats, and overalls collaged with the flag like some podunk edition of <i>Project Runway</i>. Maybe deaf displays of white supremacy felt a little more comfortable 35 miles north of Detroit in 2015.  
</p>
            
            
          
            
              
      
<p>
        Or maybe times have just changed.  
</p>
            
            
          
            
              
     <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media1.fdncms.com/metrotimes/imager/u/blog/5853977/a911918-r3-00-25a.jpg?cb=1506635468" width="980" height="662" alt="Kid Rock fans wearing the Confederate flag. - LEE DEVITO" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Lee DeVito                                          </li>                                                                                                                            <li class="imageCaption">                      Kid Rock fans wearing the Confederate flag.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        After my spontaneous high school reunion, I find it oddly apropos that my single seat is located next to an older couple that resemble possible parents of friends I might have had in high school if I had friends. I bounce in my seat with a prescribed enthusiasm and just as planned, they can't help but ask me why I'm alone and where I'm from.  
</p>
            
            
          
            
              
      
<p>
        "Oh, I live in Hamtramck," I say, still sort of bouncy. When asked if they were from Detroit, she says yes. When asked where in Detroit she says St. Clair Shores.  
</p>
            
            
          
            
              
      
<p>
        I ask her what they thought of "Senator" Kid Rock.  
</p>
            
            
          
            
              
      
<p>
        "We hope he runs for Senate. You're sitting next to a couple of Republicans," she says, crossing her arms abruptly with authoritative emphasis. "I think people are fed up and taking matters into their own hands."  
</p>
            
            
          
            
              
      
<p>
        When asked about his use of the Confederate flag, she cuts me off. "I don't think for a minute that Kid Rock is a racist. There's nothing wrong with it. It's America," she says. "Every nationality, every race has dealt with oppression in the history of the world. So don't think you're special. Everyone is oppressed."  
</p>
            
            
          
            
              
      
<p>
        She continues. "You're young. I'm older. Your generation puts up with a lot more and that's the difference," she says, wagging her finger in my face. "I think there's black and white and right and wrong."  
</p>
            
            
          
            
              
      
<p>
        I am admittedly caught off guard by her choice of words and wonder if she understood the weight of what she was implying. My guess was that she did not. Hell, I am still concerned that she didn't know the difference between St. Clair Shores and Detroit.  
</p>
            
            
          
            
              
      
<p>
        I nod with disbelief and say nothing before I am once again assaulted by the sound of an engine revving and Kid Rock's Fuck Tank.  
</p>
            
            
          
            
              
      
<p>
        As a millennial in a stadium filled with mostly baby boomers celebrating a white guy singing a song about being "Born Free," I can't help but feel maybe she was right about one thing. My generation does put up with a lot.
</p>
            
            
          
            
              
      <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media2.fdncms.com/metrotimes/imager/u/blog/5853978/a911918-r2-17-6a.jpg?cb=1506635468" width="980" height="662" alt="Kid Rock&rsquo;s Made in Detroit restaurant located within Little Caesars Arena. - LEE DEVITO" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Lee DeVito                                          </li>                                                                                                                            <li class="imageCaption">                      Kid Rock’s Made in Detroit restaurant located within Little Caesars Arena.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        <b>Day 4: Mock the vote</b>  
</p>
            
            
          
            
              
      
<p>
        Some might call this the "home stretch." I, on the other hand, consider show No. 4 the point of no return. I am weary, uninspired, and disenchanted. Regardless, I am ready for my life to return to normal.  
</p>
            
            
          
            
              
      
<p>
        Before the show, I sit outside at a picnic bench in front of the Made in Detroit restaurant eavesdropping, hoping that someone would accidentally inspire a meaningful trajectory for the day because I am struggling to see the point of any of this.  
</p>
            
            
          
            
              
      
<p>
        "They're literally to my thighs if I take my bra off," someone says. "I smell the wacky grass," someone else says, and "Fuck Google. They're fascists."  
</p>
            
            
          
            
              
      
<p>
        I am having second thoughts about this whole thing. "There are psychological repercussions with doing something like this. For a second time," I text my editor while leaning against a display of Red Wings memorabilia. "Listen, no one said you had to stay the whole time," he responds. "Let's be honest. No normal person could survive six back-to-back shows, not even a Kid Rock fan."  
</p>
            
            
          
            
              
      
<p>
        By this time, LCA has lost its new stadium smell. The whole damn place reeks of pizza, almost as if they were pumping pepperoni through the ventilation system. I upgrade my concession vices from beer to liquor, from soft pretzels to an artisanal burrito bowl, and I decide to redirect my focus on something other than my own misery.  
</p>
            
            
          
            
              
      
<p>
        The key to maintaining sanity during a project as tedious as this is the development and maintenance of rituals. By show No. 4, I have many.  
</p>
            
            
          
            
              
      
<p>
        For example, I have subconsciously deemed Kid Rock's uninspired rendition of Rod Stewart's "Maggie May" (a little less than half-way through the two-hour set) the perfect time to pee and buy another beer. During this particular break, I can't help but eavesdrop on the conversation between a bathroom attendant and an usher.  
</p>
            
            
          
            
              
      
<p>
        "You can't be racist if you have a black baby. You just can't," the attendant says, referring to Kid Rock's son. I flush and hope this conversation is still happening by the time I go to wash my hands.  
</p>
            
            
          
            
              
      
<p>
        "There have been black people here. Tonight I saw a black man with a white lady," the usher says. "Wednesday I seen a white lady with a black man. Tuesday, I seen one black couple and she said the only reason she was there was because her husband helped build this place. They got free tickets."  
</p>
            
            
          
            
              
      
<p>
        A Detroit resident of 40 some years, the usher, a black woman in her 60s, says she says she's worked every Kid Rock show since the stadium opened.  
</p>
            
            
          
            
              
      
<p>
        "Child, we ain't goin' to no damn Kid Rock, are you crazy? It's a music thing, it's not about race," she says. "Where the hell did all these damn white people come from? White people coming by the charter buses, sweetie."  
</p>
            
            
          
            
              
      
<p>
        She is out of breath here and leans her back against the bathroom wall. "Every night has been packed. But tonight... tonight it's white people to the damn ceiling."  
</p>
            
            
          
            
              
      
<p>
        I suddenly recognize her as my usher from earlier who helped me to my section. And I remember her clearly for her uproarious cheering during Rock's Senate speech.  
</p>
            
            
          
            
              
      
<p>
        I ask her what she thinks of Kid Rock's politics.  
</p>
            
            
          
            
              
      
<p>
        "Money talks, honey. Times are changing. Donald Trump paved the way for anyone who's got any money to run and if you've got enough you can win," she says. "He's probably the first person to say he's not qualified."  
</p>
            
            
          
            
              
      
<p>
        But she reminds me that it's our duty to pray for him. "After all," she continues, "he is our leader."  
</p>
            
            
          
            
              
      
<p>
        She says her daughter lives in Charlottesville. "Before Trump got in we saw twenty-some trucks drive by, had a whole parade, all of them had the Nazi flags on the trucks," she says. "It's like they were campaigning for him. I was shocked. My daughter said, 'Don't worry, mama, we see this all the time.'"  
</p>
            
            
          
            
              
      
<p>
        But she says she thinks things are different post-Trump, and post-Charlottesville. "Even if Trump gets out of office, they already out," she says, referring to white supremacists. "They're not going to just go back in. They're empowered now."  
</p>
            
            
          
            
              
      
<p>
        She says she worries about her children and her grandchildren. "I done made it through, you know," she says. "But the kids? They don't stand a chance."  
</p>
            
            
          
            
              
      
<p>
        When I ask if she would vote for Senator Kid Rock, her answer surprises.  
</p>
            
            
          
            
              
      
<p>
        "Based on tonight? Yeah I would," she says. "I don't know why. I don't know if it was the Jesus thing or what he said about the transgender thing, but I might."  
</p>
            
            
          
            
              
     <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media1.fdncms.com/metrotimes/imager/u/blog/5853973/a911918-r4-01-24.jpg?cb=1506635468" width="980" height="662" alt="He doesn&#39;t seem too upset about it. - LEE DEVITO" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Lee DeVito                                          </li>                                                                                                                            <li class="imageCaption">                      He doesn't seem too upset about it.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        <b>Day 5: Here we are now, entertain us</b>  
</p>
            
            
          
            
              
      
<p>
        I had all intentions of going to show No. 5. I really did.  
</p>
            
            
          
            
              
      
<p>
        You know when your life starts falling apart so you Google if Mercury is in Retrograde or not and when you find out it is in retrograde you feel a bit better knowing everything is sort of out of your control? This week, Kid Rock was my Mercury in Retrograde. From a broken laptop and my growing discontent with a dead-end job to an ever-depleting bank account, and sleepless night after night, I did not have it in me to subject myself to the circus and Fuck Tank and Uncle Kracker, or what is appearing to me to be empty, political theater.  
</p>
            
            
          
            
              
      
<p>
        I was depressed, and starting to doubt the wisdom of this assignment, and I had little reason to believe this night would be any different than any of the other nights. Why would someone so calculated and scripted officially announce his Senate bid (if he had intended to at all) on show 5 of 6? It didn't make sense. And if it did, on this night I just did not care. I had apparently hit my (Kid) rock bottom.  
</p>
            
            
          
            
              
      
<p>
        So I did what anyone in my position would do. I went to the Father John Misty show, instead.  
</p>
            
            
          
            
              
      
<div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media2.fdncms.com/metrotimes/imager/u/blog/5853975/a911918-r3-11-8a.jpg?cb=1506635468" width="980" height="662" alt="This Florida woman got a ticket to Kid Rock&#39;s Detroit show months ago, coincidentally allowing her to escape hurricane season. - LEE DEVITO" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Lee DeVito                                          </li>                                                                                                                            <li class="imageCaption">                      This Florida woman got a ticket to Kid Rock's Detroit show months ago, coincidentally allowing her to escape hurricane season.                    </li>                                                                                                </ul>                                                       </div>
<p>
        <b>Day 6: No alarms, no surprises</b>  
</p>
            
            
          
            
              
      
<p>
        Today marks the very last time that I will ever attend a Kid Rock show. Then again, I've said this before. But tonight is also different for another reason: Instead of the $20 cheap seat, we sprung for a main floor ticket on StubHub. I felt like Charlie with his gold-plated candy bar. Despite my weariness, truthfully, I was excited. Thrilled, even.  
</p>
            
            
          
            
              
      
<p>
        It was much easier to be happy from 28 rows back.  
</p>
            
            
          
            
              
      
<p>
        I waited for the Senate speech with bated breath. Surely, if he was truly running for Senate, he would reveal it one way or the other tonight.  
</p>
            
            
          
            
              
      
<p>
        Instead, Kid Rock does what he does best: He gives the people what they wanted, even if they had no idea what that was.  
</p>
            
            
          
            
              
      
<p>
        Not a single word out of place, the speech remains the same. There is no major announcement, no revelation, and no deviation from the scripts from the previous shows. Once I realize the joke is on me, on all of us, I grant myself permission to submit fully to Kid "the Bullgod" Rock. Good one, Kid. You really had me going.  
</p>
            
            
          
            
              
      
<p>
        Maybe the truth was right in front of our eyes all along. As this was the first time I was close enough to the stage to be able to really hear the audio and see the big screen backdrop, I finally notice the video interlude introducing "Born Free." Narrated by Kid Rock, the video shows images of small town Americana, praising the military and blue-collar workers. The line that sticks with me the most on the final night was one I missed before:  
</p>
            
            
          
            
              
      
<p>
        "The only party that matters is the one we're having tonight."  
</p>
            
            
          
            
              
      
<p>
        Then, once again, the black piano rolls out and a digital waving American flag fills the screen and Kid Rock belts out "Born Free," on time and on cue.  
</p>
            
            
          
            
              
      
<p>
        It is here that I manically laugh to myself and scream into the air. I'm fucking done. I'm fucking done!  
</p>
            
            
          
            
              
      
<p>
        As it turns out, Kid Rock and I have something in common. We are both free.  
</p>
            
            
          
            
              
     <div class="contentImageCenter" style="overflow:hidden;">                                        <img src="https://media1.fdncms.com/metrotimes/imager/u/blog/5853968/a911918-r1-16-4a.jpg?cb=1506635468" width="980" height="662" alt="Born free. - JERILYN JORDAN" />                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Jerilyn Jordan                                          </li>                                                                                                                            <li class="imageCaption">                      Born free.                    </li>                                                                                                </ul>                                                       </div>  
<p>
        <b>Epilogue</b>  
</p>
            
            
          
            
              
      
<p>
        For an entire week, all eyes were on Detroit.  
</p>
            
            
          
            
              
      
<p>
        While deadly hurricanes ravaged the south, the Midwest suffered its own almost-disaster. A slew of headlines containing the words "Kid" and "Rock" and "Senate" topped the likes of <i>Rolling Stone, Forbes, Pitchfork</i>, and <i>The</i> <i>Washington Post</i>, among others.  
</p>
            
            
          
            
              
      
<p>
        Perhaps it was much ado about nothing. The day after Kid Rock's final show, a poll is released, showing him trailing behind his would-be rival, Democrat incumbent Debbie Stabenow, by double digits. "Kid Rock would have an uphill climb against Stabenow if he were serious about getting into the race," Media Research Group president Tim Shields <a href="http://www.freep.com/story/news/local/michigan/2017/09/20/kid-rock-senate-debbie-stabenow/687263001/" target="_blank">said in a statement</a>. "His popularity as an entertainer is not transferring to the ballot." Citing an unnamed GOP source, a <i><a href="http://www.deadlinedetroit.com/articles/18316/kid_rock_has_no_intention_of_running_for_senate_republican_party_source_says#.Wcp_oyMrKM4" target="_blank">Deadline Detroit</a></i> article reports Rock never intended to run. "It's publicity 101," he says.  
</p>
            
            
          
            
              
      
<p>
        Bob Young, one of the highest profile Republicans to join the Senate race so far, recently confirmed as much. "Those who know both Kid Rock and his father say that this was a joke that kind of got away from him," he told <i><a href="http://www.detroitnews.com/story/news/politics/2017/09/22/kid-rock-mcdaniel-gop-senate/105892534/" target="_blank">The Detroit News</a></i>.  
</p>
            
            
          
            
              
      
<p>
        So was this it? Was this always, from the beginning, a calculated publicity stunt, a distraction, and, very generously, an attempt at artistic expression?  
</p>
            
            
          
            
              
      
<p>
        I was forced to care. <i>We</i> were forced to care, because there was more than a slight possibility that this was far greater than an elaborate ruse. People could have gotten hurt. Crazier things had happened... and we had no choice but to be there in case something did.  
</p>
            
            
          
            
              
      
<p>
        I can't help but feel this was the true crux of this disorienting journey into the cynical redevelopment of the 'Merican dream. Night after night, Kid Rock delivered hollow bombast to thousands of his fans — from my direct experience, a collection of the most earnest people I have ever met. OK, they do not seem to have a nuanced understanding of politics, current events, or Black Lives Matter. All they want to do is crack a cold one to "All Summer Long." And who can really blame them? Because, yeah. I like to be entertained, too. The only difference is that I know the difference.  
</p>
            
            
          
            
              
      
<p>
        But whether Kid Rock for Senate is real or not doesn't matter. They were entertained either way.  
</p>
            
            
          
            
              
      
<p>
        The only real nod to any sort of serious political effort came in the form of voter registration booths, interspersed among the Little Caesars pizza $7-super slice stands and Kid Rock's merch booths in the arena's looping concourse.  
</p>
            
            
          
            
              
      
<p>
        During one of the previous shows, I ask one of the booth's attendants, a cheerful volunteer with a nonpartisan organization whose focus is voter registration, if she thinks Kid Rock was serious about the whole Senate thing.  
</p>
            
            
          
            
              
      
<p>
        Her once happy-to-answer-my-question-smile flattens and her energy deflates. "I don't think he'll run this upcoming election. I think it's strategic, but I can't be sure," she says.  
</p>
            
            
          
            
              
      
<p>
        She then leans closer. "Listen, he'll either wake up and say, 'I'm going to fucking do it. Or he'll wake up one day and say, 'I'm not fucking doing it. But at least I took all their money.'"  
</p>
            
            
          
            
              
  <br></p>
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayoutFullWidth -->
















  
  

  
  
  

  
    <div id="PreviousNextInCategory" class="HomeTopRow ContentFullWidth ">
      <div class="prevNext">
        
          
          

          <a href="https://www.metrotimes.com/detroit/ted-leo-talks-about-the-personal-and-political-motives-behind-his-new-album/Content?oid=5553120" class="prev" title="previous">&laquo;&nbsp;Ted Leo talks about the personal and political motives behind his new album</a>

          
          
            &nbsp;&nbsp;|&nbsp;&nbsp;
          
        
        
          
          

            <a href="https://www.metrotimes.com/detroit/afrobeat-descendants-antibalas-to-play-otus-supply-in-ferndale/Content?oid=5854224" class="next" title="next">Afrobeat descendants Antibalas to play Otus Supply in Ferndale&nbsp;&raquo;</a>
        
      </div>
    </div>
  




  
  

















  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="HomeTopRow ContentFullWidth ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content%3Foid%3D5853633&text=To%20understand%20Kid%20Rock%E2%80%99s%20politics%2C%20we%20attempted%20to%20go%20to%20all%20six%20of%20his%20shows%20at%20Little%20Caesars%20Arena" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.metrotimes.com/detroit/Tools/EmailFriend?oid=5853633" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?mode=print&amp;oid=5853633" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-51f9437a2abb7e86" addthis:url="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633" addthis:title="To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena" addthis:description="Senator Kid Rock?" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51f9437a2abb7e86", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  

<div id="JumptoComments" class="HomeTopRow ContentFullWidth ">
  <a href="#Disqus">Jump to comments</a>
</div><!-- End JumptoComments -->


  <div id="ArchiveLink" class="HomeTopRow ContentFullWidth ">
    <p class="moreArticles">
      
        <a href="https://www.metrotimes.com/detroit/ArticleArchives?category=2135218">More Local Music &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->


    </div>   
    
  <div id="gridLeftColumn">    
      
    <!-- Zone B -->
      <div id="leftColumnTopLeft">
        
      </div> 
      
      <!-- Zone C -->
      <div id="leftColumnTopRight">
        
      </div>
        
      <div class="clear"></div>
   
      <!-- Zone D -->
      <div id="leftColumnCenter">
        










  








    
    
    
    








  <!-- xxx: No location -->






  

  

  
  

  

  























  
  
      <div id="RecentByTag" class="HomeLeftColumn ContentFullWidth ">
        <h3 class="latestcity_slang">
          <span class="headingText">
          
            Speaking of...
          
          </span>      
        </h3>
        
        <ul class="moduleList">
    
    
    
          

    <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/27/lana-del-rey-is-coming-to-detroit?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/5876587/20374605_1662902327085544_5659547606835405058_n.jpg" alt="Lana Del Rey is coming to Detroit" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/27/lana-del-rey-is-coming-to-detroit?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">Lana Del Rey is coming to Detroit</a>
    </h4>
    <div class="date">Sep 27, 2017</div>
  </li>

    
  
    
    
          

    <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/the-scene/archives/2017/09/27/a-live-game-of-thrones-experience-is-coming-to-little-caesars-arena?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/5874614/tot_dracarys_concept_pr.jpg" alt="A live &#39;Game of Thrones&#39; experience is coming to Little Caesars Arena" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/the-scene/archives/2017/09/27/a-live-game-of-thrones-experience-is-coming-to-little-caesars-arena?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">A live 'Game of Thrones' experience is coming to Little Caesars Arena</a>
    </h4>
    <div class="date">Sep 27, 2017</div>
  </li>

    
  
    
    
          

    <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/news-hits/archives/2017/09/22/cass-park-residents-hit-by-parking-squeeze-after-pizzarena-opening?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/5746671/image2_3_.jpg" alt="Cass Park residents hit by parking squeeze after Little Caesars Arena opening" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/news-hits/archives/2017/09/22/cass-park-residents-hit-by-parking-squeeze-after-pizzarena-opening?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">Cass Park residents hit by parking squeeze after Little Caesars Arena opening</a>
    </h4>
    <div class="date">Sep 22, 2017</div>
  </li>

    
  
        
          <li class="l0 storyItem more">
            <a href="https://www.metrotimes.com/detroit/ArticleArchives?tag=kid%20rock%7C%7Clittle%20caesars%20arena%7C%7CKid%20Rock%20for%20Senate" class="more">More &raquo;</a>
          </li>
        
        </ul>
      </div>
    
  




  <div id="StoryTags" class="HomeLeftColumn ContentFullWidth ">
    <p class="tags">Tags: <a href="/detroit/ArticleArchives?category=2135218" rel="tag">Local Music</a>, <a href="/detroit/ArticleArchives?tag=kid%20rock" rel="tag">kid rock</a>, <a href="/detroit/ArticleArchives?tag=little%20caesars%20arena" rel="tag">little caesars arena</a>, <a href="/detroit/ArticleArchives?tag=Kid%20Rock%20for%20Senate" rel="tag">Kid Rock for Senate</a>, <a href="/detroit/ArticleArchives?contentFeature=2135367" rel="tag">Cover Story</a></p>          
  </div> <!-- end StoryTags -->



<div id="AdNativeEndofArticle" class="HomeLeftColumn ContentFullWidth ">
  <!-- /43707298/DET_DesktopNative -->
          <div id="div-gpt-ad-det_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/DET_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_desktopnative-3');
                  });
              </script>
          </div>
</div>




  

  

  

    

    

    

    
      <div id="Disqus" class="HomeLeftColumn ContentFullWidth ">
        <div id="disqus_thread"></div>
        <script type="text/javascript">
        <!--
          var disqus_shortname = "metrotimes";
          var disqus_identifier = "metrotimes:5853633";
          var disqus_url = "https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633";
          var disqus_title = "To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena";
          (function() {
              var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
              dsq.src = "https://" + disqus_shortname + ".disqus.com/embed.js";
              (document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
          })();
        // -->
        </script>
        <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
      </div>
    

  










  
  
      <div id="LatestInCategory" class="HomeLeftColumn ContentFullWidth ">
        <h3 class="latestlocal_music"><span class="headingText">Latest in Local Music</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/detroit/afrobeat-descendants-antibalas-to-play-otus-supply-in-ferndale/Content?oid=5854224&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/5854222/antibalas_-_photo_credit_michael_davis-hi-res.jpeg" alt="Afrobeat descendants Antibalas to play Otus Supply in Ferndale" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/detroit/afrobeat-descendants-antibalas-to-play-otus-supply-in-ferndale/Content?oid=5854224&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">Afrobeat descendants Antibalas to play Otus Supply in Ferndale</a>
    </h4>
    <div class="date">Sep 27, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/detroit/how-protomartyr-became-one-of-detroits-biggest-indie-bands-in-years/Content?oid=5551847&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/5551846/protomartyr_13_-_dmc_0015.jpg" alt="How Protomartyr became one of Detroit&rsquo;s biggest indie bands in years" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/detroit/how-protomartyr-became-one-of-detroits-biggest-indie-bands-in-years/Content?oid=5551847&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">How Protomartyr became one of Detroit’s biggest indie bands in years</a>
    </h4>
    <div class="date">Sep 13, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/detroit/why-i-had-the-most-sex-of-my-adult-life-to-father-john-mistys-pure-comedy/Content?oid=5552977&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/5552974/fatherjohnmisty_2017_promo_13_guylowndes_3840x5760_300_copy.jpg" alt="Why I had the most sex of my adult life to Father John Misty&rsquo;s &lsquo;Pure Comedy&rsquo;" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/detroit/why-i-had-the-most-sex-of-my-adult-life-to-father-john-mistys-pure-comedy/Content?oid=5552977&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">Why I had the most sex of my adult life to Father John Misty’s ‘Pure Comedy’</a>
    </h4>
    <div class="date">Sep 13, 2017</div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.metrotimes.com/detroit/ArticleArchives?category=2135218&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    



    

    



  

  

  
    <div id="AltWeekliesDynamic" class="HomeLeftColumn ContentFullWidth " style="display:none">
      <h3><span class="headingText">Related Stories from <a href="http://www.altweeklies.com/" target="_blank">Altweeklies.com</a></span></h3>
  
      <script type="text/javascript" src="/foundation/scripts/altweeklies-include.js"></script>
      <script type="text/javascript"><!--
        altweekliesInclude({
            id: "AltWeekliesDynamic-Results",
            max: "3",
            section: "music",
            pubexclude: [
      
      "19"
      
    ],
            summaries: true,
            callback: function (t) {
                if (t.match(/\S/)) $("AltWeekliesDynamic").show();
            }
        });
      //--></script>
  
      <div id="AltWeekliesDynamic-Results"></div>
    </div>
  










  

  

  
    <div id="MorebyThisAuthorWrapper" class="HomeLeftColumn ContentFullWidth Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="HomeLeftColumn ContentFullWidth ">
            <h3><span class="headingText">More by Jerilyn Jordan</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/18/enter-the-boomiverse-at-big-bois-majestic-theatre-show?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/5551175/big-boi-white-fur_1_.jpg" alt="Enter the Boomiverse at Big Boi&#39;s Majestic Theatre show" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/18/enter-the-boomiverse-at-big-bois-majestic-theatre-show?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Enter the Boomiverse at Big Boi's Majestic Theatre show</a>
    </h4>
    <div class="date">Sep 18, 2017</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/16/seu-jorge-is-bringing-a-unique-david-bowie-tribute-to-royal-oak?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/5550879/seu-jorge_1_.png" alt="Seu Jorge is bringing a unique David Bowie tribute to Royal Oak" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/16/seu-jorge-is-bringing-a-unique-david-bowie-tribute-to-royal-oak?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Seu Jorge is bringing a unique David Bowie tribute to Royal Oak</a>
    </h4>
    <div class="date">Sep 16, 2017</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/15/electro-pop-duo-sylvan-esso-bring-crisp-pop-roundness-to-the-crofoot?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/5551043/sylvan_esso.jpg" alt="Electro pop duo Sylvan Esso bring crisp pop roundness to the Crofoot" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/city-slang/archives/2017/09/15/electro-pop-duo-sylvan-esso-bring-crisp-pop-roundness-to-the-crofoot?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Electro pop duo Sylvan Esso bring crisp pop roundness to the Crofoot</a>
    </h4>
    <div class="date">Sep 15, 2017</div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.metrotimes.com/detroit/ArticleArchives?author=3983126" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

  
    
        <div id="PeopleWhoLiked" class="HomeLeftColumn ContentFullWidth ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/detroit/iggy-pop-makes-his-detroit-return/Content?oid=2435320&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/2435319/iggyrecordreview.jpg" alt="Iggy Pop makes his Detroit return" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/detroit/iggy-pop-makes-his-detroit-return/Content?oid=2435320&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">Iggy Pop makes his Detroit return</a>
    </h4>
    <div class="date">Mar 30, 2016</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/city-slang/archives/2016/02/08/beyonce-plays-ford-field-may-29-world-tour-to-donate-support-to-flint-water-victims?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/2395101/maxresdefault.jpg" alt="Beyonce plays Ford Field May 29; world tour to donate support to Flint water victims" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/city-slang/archives/2016/02/08/beyonce-plays-ford-field-may-29-world-tour-to-donate-support-to-flint-water-victims?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">Beyonce plays Ford Field May 29; world tour to donate support to Flint water victims</a>
    </h4>
    <div class="date">Feb  8, 2016</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      <a href="https://www.metrotimes.com/city-slang/archives/2016/02/26/jack-white-appears-on-the-muppets-this-tuesday-march-1?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/2398313/12742719_10153929657141800_7246360309534763150_n.jpg" alt="Jack White&#39;s going to be on The Muppets" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.metrotimes.com/city-slang/archives/2016/02/26/jack-white-appears-on-the-muppets-this-tuesday-march-1?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">Jack White's going to be on The Muppets</a>
    </h4>
    <div class="date">Feb 26, 2016</div>
  </li>
      
      
    
          </ul>
        </div>
      
               

      </div>
      
      <!-- Zone I -->
      <div id="leftColumnBtmLeft">
        
      </div> 

      <!-- Zone J -->
      <div id="leftColumnBtmRight">
       
      </div> 
      
      <div class="clear"></div>
      <!-- End gridLeftColumn --></div> 
      
      
    <div id="gridRightSidebar">
      <!-- Zone E -->
        <div id="homeSidebarTop">
        




  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  













<div id="SearchRightCol" class="HomeSidebar ContentFullWidth  search-wrap">
    
    <form class="prepTextForm" id="searchbox_017793458706336421686:uqt4fqpywfe" action="https://posting.metrotimes.com/detroit/Search">
      <input type="hidden" name="cx" value="017793458706336421686:uqt4fqpywfe" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="https://posting.metrotimes.com/detroit/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="https://www.metrotimes.com/detroit/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="https://www.metrotimes.com/detroit/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="https://www.metrotimes.com/detroit/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            window.location = newLocation + "?keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->



  <div id="NewsletterSignup" class="HomeSidebar ContentFullWidth ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <!-- BEGIN: Constant Contact Email List Form Button -->
<h3>Never miss a beat</h3>
<a href="/detroit/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color: rgb(217, 31, 52);font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
<!-- END: Constant Contact Email List Form Button -->
    </div>
  </div>
  
  <div id="PromoGraphicLinkCustom" class="HomeSidebar ContentFullWidth ">
    <ul class="componentBody">
      
        <li class="left">
          
            <img src="/binary/5422/Drink_150x150.jpg" />
          
        </li>    
      
        <li class="right">
          
            <img src="/binary/6a61/Flavor_150x150.jpg" />
          
        </li>    
      
    </ul>
    
  </div>
<div id="AdMediumRectangle3300x250" class="HomeSidebar ContentFullWidth ">
  <!-- /43707298/DET_300x250 -->
          <div id="div-gpt-ad-det_300x250-3" style="" data-content-type="ad" data-slot="/43707298/DET_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_300x250-3');
                  });
              </script>
          </div>
</div>









<div id="TabbedPopularity" class="HomeSidebar ContentFullWidth ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
    <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    
        <ol class="moduleList">
      
      
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/city-slang/archives/2017/09/28/punk-rockers-against-me-will-perform-at-the-majestic-on-sunday?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Punk rockers Against Me! will perform at the Majestic on Sunday <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/city-slang/archives/2017/09/28/rob-zombie-to-melt-faces-at-riff-fest-this-weekend?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Rob Zombie to melt faces at Riff Fest this weekend <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/afrobeat-descendants-antibalas-to-play-otus-supply-in-ferndale/Content?oid=5854224&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Afrobeat descendants Antibalas to play Otus Supply in Ferndale <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/alice-cooper-still-has-nightmares-to-share/Content?oid=5238720&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Alice Cooper still has nightmares to share <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/city-slang/archives/2017/09/27/lana-del-rey-is-coming-to-detroit?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Lana Del Rey is coming to Detroit <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>  

  

  <div class="popularityBody" style="display:none">
    

    
    <div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://disqus.com/forums/metrotimes/popular_threads_widget.js?num_items=5&hide_avatars=1&avatar_size=32&excerpt_length=200"></script></div>
  </div>
  
  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="https://www.metrotimes.com/detroit/IssueArchives?issue=5853631&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/5853631/a1b5/51-Cover_V2.jpg" alt="Issue Cover" />
          
        </a>
        <p>September 27- 3, 2017</p>
      </div>
    
    
        <ol class="moduleList">
      
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/to-understand-kid-rocks-politics-we-attempted-to-go-to-all-six-of-his-shows-at-little-caesars-arena/Content?oid=5853633&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">To understand Kid Rock’s politics, we attempted to go to all six of his shows at Little Caesars Arena <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/mayor-duggans-team-grows-43-percent-while-city-loses-cops-firefighters/Content?oid=5854863&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Mayor Duggan’s team grows 43 percent, while city loses cops, firefighters <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/schuette-grasping-for-duty/Content?oid=5853981&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Schuette, grasping for duty <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/big-money-will-be-made-when-michigans-medical-marijuana-industry-goes-legit-but-who-will-make-it/Content?oid=5854382&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Big money will be made when Michigan’s medical marijuana industry goes legit — but who will make it? <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/review-boostan-cafe-fuses-the-flavors-of-three-continents/Content?oid=5854089&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Review: Boostan Cafe fuses the flavors of three continents <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/afrobeat-descendants-antibalas-to-play-otus-supply-in-ferndale/Content?oid=5854224&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Afrobeat descendants Antibalas to play Otus Supply in Ferndale <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/the-true-story-of-an-infamous-1973-tennis-match-shows-how-the-battle-for-gender-equality-has-come-and-how-far-it-still-has-to-go/Content?oid=5854228&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">'Battle of the Sexes' shows how far gender equality has come — and how far it still has to go <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/kobie-solomon-finished-his-most-ambitious-mural-yet/Content?oid=5854378&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Kobie Solomon finished his most ambitious mural yet <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/savage-love-at-the-palace/Content?oid=5854582&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Savage Love: At the palace <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.metrotimes.com/detroit/horoscopes-sept-27-oct-3/Content?oid=5853748&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Horoscopes (Sept. 27-Oct. 3) <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
    // 
    jQuery('div.tabs div#tabLatest').click();
});
//-->
</script>
<!-- End #TabbedPopularity -->
<div id="PhotoSlideshows" class="HomeSidebar ContentFullWidth ">
  <h2><a href="http://photos.metrotimes.com/" target="_blank">Newest Slideshows</a></h2>
  <iframe src="https://photos.metrotimes.com/thumbnail-scroller-square/" 
          height="419" 
          width="364"
          scrolling="no" 
          frameborder="0"></iframe>
</div>
<!-- End #PhotoSlideshows -->














    <div id="SpecialIssues" class="HomeSidebar ContentFullWidth ">
      <h2><a href="https://www.metrotimes.com/detroit/special-issues/Section?oid=2135208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/detroit/detroit-people/Category?oid=2349188&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/metrotimes/imager/u/original/4911101/ppl.jpg);">
      <span class="grayRedBox">The People Issue</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/a-radicals-oral-history-of-detroit-in-1967/Content?oid=4618445&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/metrotimes/imager/u/original/4682744/1967-2.jpg);">
      <span class="grayRedBox">A radical’s oral history of 1967</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/2017-summer-guide/Content?oid=4063528&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/metrotimes/imager/u/original/4667455/summer.jpg);">
      <span class="grayRedBox">Summer Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/ArticleArchives?category=2216644&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/metrotimes/imager/u/original/4592045/mim2017-2.jpg);">
      <span class="grayRedBox">Made in Michigan</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/welcome-to-the-best-of-detroit-2017/BestOf?oid=3497208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/metrotimes/imager/u/original/3499154/dmt_bod2017_cover_v4-copy.jpg);">
      <span class="grayRedBox">Best of Detroit</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/IssueArchives?issue=3036865&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/metrotimes/imager/u/original/3038895/anman17.jpg);">
      <span class="grayRedBox">Annual Manual</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/IssueArchives?issue=5467676&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/metrotimes/imager/u/original/2477571/flavor.jpg);">
      <span class="grayRedBox">FLAVOR</span>
    </a>
  </div>
  

      <a href="https://www.metrotimes.com/detroit/special-issues/Section?oid=2135208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  

        </div>
        
        <!-- Zone F -->
        <div id="homeSidebarLeft">
          
        </div>
        <!-- Zone G -->
        <div id="homeSidebarRight">
          
        </div>
        <div class="clear"></div>
        <!-- Zone H -->
      <div id="homeSidebarBtm">
        
      </div>  
    </div>
    <div class="clear"></div>
    </div><!-- end gridMain -->
    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter ContentFullWidth ">
  <div class="footerCustomInfo">
    <h2>Metro Times</h2>
    <p>1200 Woodward Heights Blvd</p>
    <p>Ferndale, MI 48220</p>
    <p>Main: (313) 961-4060</p>
    <p>Advertising: (313) 961-4060</p>
    <p>Classified: (313) 961-4060</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="https://www.metrotimes.com/detroit/StaffDirectory/Page">Contact MT</a></li>
        <li><a target="_top" href="https://www.metrotimes.com/detroit/Advertise/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
        <li><a target="_top" href="https://www.metrotimes.com/detroit/Careers/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2017 Detroit Metro Times.</p>
    </div>
    <div class="footerRssLink">
      <a href="https://www.metrotimes.com/detroit/Syndication" class="RSSLink">RSS Feeds</a>
    </div>    

    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.metrotimes.com/detroit/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.metrotimes.com/detroit/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.metrotimes.com/detroit/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdFooter728x90" class="GlobalFooter ContentFullWidth ">
  <!-- /43707298/DET_728x90 -->
          <div id="div-gpt-ad-det_728x90-2" style="" data-content-type="ad" data-slot="/43707298/DET_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-det_728x90-2');
                  });
              </script>
          </div>
</div>


















<div id="FooterNavigation" class="GlobalFooter ContentFullWidth ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/news-and-views/Section?oid=2135207" 
               target="_">
              News
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/news-and-views/Section?oid=2135207" >News Home</a></li>
          
            <li><a href="/Blogs/archives/news-blog/" >News Blog</a></li>
          
            <li><a href="/detroit/savage-love/Category?oid=2162739" >Savage Love</a></li>
          
            <li><a href="/detroit/feedback/Category?oid=2162740" >Letters</a></li>
          
            <li><a href="/detroit/IssueArchives?issue=this%20week" target="_blank">e-Edition</a></li>
          
            <li><a href="/detroit/joblistings/Page" >Local Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/blogs/Blogs/" 
               target="_">
              Blogs
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/blogs/Blogs/" >Blog Home</a></li>
          
            <li><a href="/Blogs/archives/news-blog/" >News Blog</a></li>
          
            <li><a href="/Blogs/archives/music-blog/" >Music Blog</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/music/Section?oid=2124980" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/music/Section?oid=2124980" >Music Home</a></li>
          
            <li><a href="/Blogs/archives/music-blog/" >Music Blog</a></li>
          
            <li><a href="/detroit/EventSearch?eventSection=2167738" >Search Music Events</a></li>
          
            <li><a href="/detroit/Events/AddEvent" >Add Music Events</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/arts-and-culture/Section?oid=2124977" 
               target="_">
              Arts and Culture
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/arts-and-culture/Section?oid=2124977" >Arts and Culture Home</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/EventSearch" 
               target="_">
              Events
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/EventSearch" >Events Home</a></li>
          
            <li><a href="/detroit/EventSearch" >Search Calendar</a></li>
          
            <li><a href="/detroit/Events/AddEvent" >Add Calendar Event</a></li>
          
            <li><a href="/detroit/FreeStuff" >Free Stuff</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/food-and-drink/Section?oid=2124982" 
               target="_">
              Dining
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/food-and-drink/Section?oid=2124982" >Dining Home</a></li>
          
            <li><a href="/detroit/LocationSearch?locationSection=2124727&guide=2124367" >Find a Restaurant</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/ArticleArchives" 
               target="_">
              Archives
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/ArticleArchives" >Search Archives</a></li>
          
            <li><a href="/detroit/ArticleArchives" >Search Authors</a></li>
          
            <li><a href="/detroit/IssueArchives" >Search Issues</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/welcome-to-the-best-of-detroit-2017/BestOf?oid=3497208" 
               target="_">
              Best of Detroit
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/BestOf" >Best of Detroit Home</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/special-issues/Section?oid=2135208" 
               target="_">
              Special Issues
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.metrotimes.com/detroit/fall-arts-guide/Category?oid=2249726">Fall Arts Guide</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/sloshed/Category?oid=2135227">Sloshed</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/the-halloween-issue/Category?oid=2261605">The Halloween Issue</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/gift-guide/Category?oid=2270184">Gift Guide</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/flavor/Category?oid=2477494">Flavor</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/lust-issue/Category?oid=2135225">Lust Issue</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/annual-manual/Category?oid=2135220">Annual Manual</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/summer-guide/Category?oid=2135233">Summer Guide</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/made-in-michigan/Category?oid=2216644">Made in Michigan</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/the-people-issue/Category?oid=2349188">The People Issue</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/college-guide/Category?oid=2135226">College Guide</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/festival-guide/Category?oid=2365752">Festival Guide</a></li>
  
    <li><a href="https://www.metrotimes.com/detroit/detroit-lions-season-preview/Category?oid=2243480">Detroit Lions Season Preview</a></li>

          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>Classified</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/joblistings/Page" >Local Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://metrotimes.com/facebook" target="_blank">Facebook</a></li>
          
            <li><a href="http://www.twitter.com/metrotimes" target="_blank">Twitter</a></li>
          
            <li><a href="http://instagram.com/metrotimes" target="_blank">Instagram</a></li>
          
            <li><a href="https://plus.google.com/114596149904731441663/about" target="_blank">Google Plus</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>About Metro Times</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/AboutMetroTimes/Page" >About Us</a></li>
          
            <li><a href="/detroit/Advertise/Page" >Advertise</a></li>
          
            <li><a href="/detroit/Policies/Page" >Policies</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigation -->
<div id="footerCopyright">
  <p>
   &copy; 2017
   Detroit Metro Times 
   <br><br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div>
    </div><!-- end gridFooter -->
  
</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->
    </body>
</html>
  

