























































    
         
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content Default" />
  
    <meta name="oid" content="3983499" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=065f4b0f2bae8126a57afe3f67f243d1" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=065f4b0f2bae8126a57afe3f67f243d1" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=065f4b0f2bae8126a57afe3f67f243d1" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=065f4b0f2bae8126a57afe3f67f243d1" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Whole Site" href="http://www.metrotimes.com/detroit/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: News &amp; Views Section" href="http://www.metrotimes.com/detroit/Rss.xml?oid=2135207" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Stir It Up" href="http://www.metrotimes.com/detroit/Rss.xml?oid=3317819" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Detroit Metro Times RSS: Comments on Mulenga and the chickens" href="http://www.metrotimes.com/detroit/Rss.xml?id=comments&amp;oid=3983499" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=c570393ad8"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=c570393ad8"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.metrotimes.com\/detroit\/Profile", "http:\/\/posting.metrotimes.com\/detroit\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="368071155345-fr5a01rd2lpbd03le6ivqgfnbb1jmfak.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->

<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />
<!-- End google fonts -->

<!-- Google Verification -->   
<script type="text/javascript" src="https://www.google.com/jsapi?key=ABQIAAAAtqeztvH8NEF24UuVX_R6nBQLskUi0KWLKDoC09NTum5Tpi1QMRQqbHK1yVFxKdfvbU15YPVeoQUgEA"></script>
<!-- End Google Verification -->

<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>
              googletag.cmd.push(function() { 
            Foundation = Foundation || {};
            Foundation.Ad = Foundation.Ad || {};
            Foundation.Ad.slots = Foundation.Ad.slots || {};
                Foundation.Ad.slots['div-gpt-ad-det_reskin'] = googletag
        .defineOutOfPageSlot('/43707298/DET_Reskin', 'div-gpt-ad-det_reskin')
        .setTargeting('oop', ['reskin'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-det_desktopinterstitial'] = googletag
        .defineOutOfPageSlot('/43707298/DET_DesktopInterstitial', 'div-gpt-ad-det_desktopinterstitial')
        .setTargeting('oop', ['desktop-interstitial'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-det_desktopnative_2'] = googletag
          .defineOutOfPageSlot('/43707298/DET_DesktopNative', 'div-gpt-ad-det_desktopnative-2')
          .setTargeting('oop', ['native-Inline'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
        Foundation.Ad.slots['div-gpt-ad-det_desktopnative_3'] = googletag
          .defineOutOfPageSlot('/43707298/DET_DesktopNative', 'div-gpt-ad-det_desktopnative-3')
          .setTargeting('oop', ['native-EndOfArticle'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-det_300x250_1'] = googletag
        .defineSlot('/43707298/DET_300x250', [300,250], 'div-gpt-ad-det_300x250-1')
        .setTargeting('placement',['ATF'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
      // Debug output 1st Medrect
      Foundation.Ad.slots['div-gpt-ad-det_300x250_2'] = googletag
        .defineSlot('/43707298/DET_300x250', [300,250], 'div-gpt-ad-det_300x250-2')
        .setTargeting('placement',['BTF'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
      // Debug output 2nd Medrect
        Foundation.Ad.slots['div-gpt-ad-det_300x250_3'] = googletag
          .defineSlot('/43707298/DET_300x250', [[300,250], [300,600]], 'div-gpt-ad-det_300x250-3')
          .setTargeting('placement',['BTF'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
        // Debug output 3rd Medrect
                Foundation.Ad.slots['div-gpt-ad-det_728x90_1'] = googletag
          .defineSlot('/43707298/DET_728x90', [728, 90], 'div-gpt-ad-det_728x90-1')
          .setTargeting('placement',['ATF'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
      Foundation.Ad.slots['div-gpt-ad-det_728x90_2'] = googletag
        .defineSlot('/43707298/DET_728x90', [728, 90], 'div-gpt-ad-det_728x90-2')
        .setTargeting('placement',['BTF'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-det_970x90'] = googletag
        .defineSlot('/43707298/DET_970x90', [[970,90], [970,250]], 'div-gpt-ad-det_970x90')
        .setTargeting('placement',['ATF'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                googletag.pubads().setTargeting('template', ["Content"]);
                googletag.pubads().setTargeting('media', ["screen"]);
                googletag.pubads().setTargeting('section', ["newsviews"]);
                googletag.pubads().setTargeting('category', ["StiritUp"]);
                googletag.pubads().setTargeting('oid', ["3983499"]);
                googletag.pubads().setTargeting('vertical', ["news"]);
                googletag.pubads().setTargeting('category_type', ["Story"]);
                googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
              googletag.enableServices();
                Foundation.Ad.refresh = function (id) {
                  if (id && Foundation.Ad.slots[id]) {
                    googletag.pubads().refresh([Foundation.Ad.slots[id]]);
                  }
                  else {
                    googletag.pubads().refresh();
                  }
                };
                Foundation.Ad.refreshlockout = false;
                if (window.jQuery) {
                  jQuery(document).on("foundation:ad:refresh", function(event) {
                    if (Foundation.Ad.refreshlockout == false) {
                      Foundation.Ad.refreshlockout = true;
                      window.setTimeout(function () {
                        Foundation.Ad.refreshlockout = false;
                      }, 5000);
                      Foundation.Ad.refresh();
                    }
                  });
                }
              }); 
          </script>

<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-643668-1', 'metrotimes.com');
    ga('send', 'pageview', { 'dimension1': 'newsviews', 'dimension2': 'news' });
    </script>
  
  <!-- End Google Analytics -->
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Mulenga and the chickens | Stir It Up | Detroit Metro Times" />
  <meta name="description" content="There I was, bouncing around in the passenger seat of a borrowed pickup truck with a blindfold over my eyes. Mulenga Harangua was at the..." />
  <meta name="keywords" content="News, Blog, Culture, Dining, Events" />
  <title>Mulenga and the chickens | Stir It Up | Detroit Metro Times</title>

  
  
  
    <meta name="author" content="Larry Gabriel">
  

  
  
  <meta name="news_keywords" content="news, blog, culture, dining, events" />

  
  
  
    <link rel="image_src" href="https://media1.fdncms.com/metrotimes/imager/u/slideshow/3983498/larry.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/metrotimes/imager/u/slideshow/3983498/larry.jpg" />
  

  
    
      <link rel="canonical" href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499&media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" />
    
  

  
    <meta property="fb:app_id" content="310950202407744" />
  

  
  <meta property="og:site_name" content="Detroit Metro Times" />
  <meta property="og:title" content="Mulenga and the chickens" />
 
  
    <meta property="og:image" content="https://media1.fdncms.com/metrotimes/imager/u/slideshow/3983498/larry.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="720" />
    
  

  
  
    <meta property="og:description" content="There I was, bouncing around in the passenger seat of a borrowed pickup truck with a blindfold over my eyes. Mulenga Harangua was at the..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">3983499</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170531015709</Attribute>
        <Attribute name="creationdate">20170530171239</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20170531010000</Attribute>
            <Attribute name="releasedate">20170531</Attribute>
            <Attribute name="releaseepoch">1496206800</Attribute>
            <Attribute name="title">Mulenga and the chickens</Attribute>
            <Attribute name="author">2135311</Attribute>
            <Attribute name="authorname">Larry Gabriel</Attribute>
            <Attribute name="authorsortname">Gabriel, Larry</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.metrotimes.com\/detroit\/mulenga-and-the-chickens\/Content?oid=3983499"
          },
          "headline": "Mulenga and the chickens",
          
            "description": "There I was, bouncing around in the passenger seat of a borrowed pickup truck with a blindfold over my eyes. Mulenga Harangua was at the wheel driving us through a maze to his new secret spot.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/metrotimes\/imager\/u\/original\/3983498\/larry.jpg",
              "width": 1280,
              "height": 1536,
              "@type": "ImageObject"
            },
          
          "datePublished": "2017-05-31T01:00:00",
          "dateModified": "2017-05-31T01:57:09",
          
            "author": {
              "name": "Larry Gabriel",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Detroit Metro Times",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.metrotimes.com\/imager\/b\/google-amp-logo\/808579\/8e1e\/MT_Redbkgd.png",
                "width": 501,
                "height": 501,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/metrotimes/imager/u/slideshow/3983498/larry.jpg">

    
    

    

    <meta name="twitter:site" content="">
    <meta name="twitter:title" content="Mulenga and the chickens">
    <meta name="twitter:description" content="There I was, bouncing around in the passenger seat of a borrowed pickup truck with a blindfold over my eyes. Mulenga Harangua was at the...">
  
</head>





  <body id="Content" class="ContentDefault Iapetus10Zone newsviews StiritUp">




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PHZV5V"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PHZV5V');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="AdInterstitial" class="Leader ContentDefault ">
  <!-- /43707298/DET_DesktopInterstitial -->
          <div id="div-gpt-ad-det_desktopinterstitial" style="" data-slot="/43707298/DET_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_desktopinterstitial');
                });
            </script>
          </div>
</div>
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
        
        
          Switch to the <a href="http://m.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  











<div id="LogoHeader" class="GlobalHeader ContentDefault ">
  
    
    <div id="logoLeft">      
      <a href="http://www.metrotimes.com/" title="Detroit Metro Times">Detroit Metro Times</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/DET_728x90 -->
          <div id="div-gpt-ad-det_728x90-1" style="" data-slot="/43707298/DET_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_728x90-1');
                });
            </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->
















  <div id="NavigationHorizontal" class="GlobalHeader ContentDefault ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_News">
          <a href="http://www.metrotimes.com/detroit/news-and-views/Section?oid=2135207"  class="subnav_link" id="SNAVL_News">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ArtsCulture">
          <a href="http://www.metrotimes.com/detroit/arts-and-culture/Section?oid=2124977"  >Arts &amp; Culture</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_FoodDrink">
          <a href="http://www.metrotimes.com/detroit/food-and-drink/Section?oid=2124982"  >Food &amp; Drink</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="http://www.metrotimes.com/detroit/music/Section?oid=2124980"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Slideshows">
          <a href="http://photos.metrotimes.com"  >Slideshows</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Calendar">
          <a href="http://www.metrotimes.com/detroit/EventSearch"  >Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_BestOf">
          <a href="http://www.metrotimes.com/detroit/BestOf"  >Best Of</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Giveaways">
          <a href="http://www.metrotimes.com/detroit/FreeStuff"  >Giveaways</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Subscribe">
          <a href="http://www.metrotimes.com/detroit/NewsletterSignup/Page"  >Subscribe</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_News" style="display:none;">
          

          

          <li class="">
            <a href="http://www.metrotimes.com/detroit/IssueArchives?issue=this%20week"  title="">e-Edition</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.metrotimes.com/detroit/joblistings/Page"  title="">Local Job Listings</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>

    
  


<!-- End #NavigationHorizontal --><div id="AdPencilBar" class="GlobalHeader ContentDefault ">
  <!-- /43707298/DET_970x90 -->
          <div id="div-gpt-ad-det_970x90" style="" data-slot="/43707298/DET_970x90" data-output="asynchronous" data-width="970" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_970x90');
                });
            </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
    <div id="StoryBreadcrumb" class="SpanningFeature ContentDefault ">
      <p class="issueInfo">
        <span class="date">
          
            <a href="http://www.metrotimes.com/detroit/IssueArchives?issue=3982066">May 31, 2017</a>
          
        </span>

  			
          <a href="http://www.metrotimes.com/detroit/news-and-views/Section?oid=2135207">News & Views</a>
        
        
          &raquo; <a href="http://www.metrotimes.com/detroit/ArticleArchives?category=3317819">Stir It Up</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  





  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: http://www.metrotimes.com
    var.publicDesktopServer = http://www.metrotimes.com
    var.shareUrl = http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499
    s/http\:\/\/www\.metrotimes\.com/http\:\/\/www\.metrotimes\.com/
    var.shareUrl = http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499
  -->




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature ContentDefault ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=http%3A//www.metrotimes.com/detroit/mulenga-and-the-chickens/Content%3Foid%3D3983499&text=Mulenga%20and%20the%20chickens" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="http://posting.metrotimes.com/detroit/Tools/EmailFriend?oid=3983499" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="printAction" title="Print" href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?mode=print&amp;oid=3983499" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-51f9437a2abb7e86" addthis:url="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" addthis:title="Mulenga and the chickens" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51f9437a2abb7e86", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




  

  

  
    <div id="StoryHeader" class="SpanningFeature ContentDefault  ">
      <div class="storyHead">
        <h1 class="headline headline-3983499">Mulenga and the chickens&nbsp;</h1>        
        
        
          

          <cite class="byline">
            By <a href="http://www.metrotimes.com/detroit/ArticleArchives?author=2135311" rel="author">Larry Gabriel</a>
               
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  








  
  
  
  




  
  
    <div id="EmbeddedSidebar" class="SpanningFeature ContentDefault  ">
      <div class="sidebar">
        <div id="ImageFlipBook" class="Sidebar ContentDefault ">
      <div id="ImageFlipBook:flipBook" class="flipBook">
      
        
        
          <div class="photoMain">
            <!-- data-orig-width="1280" -->
            <span class="clicktozoom">
              
                click to enlarge
              
            </span>
            
            
            
              <a rel="ImageFlipBook_imgGroup" class="zoomable" href="https://media1.fdncms.com/metrotimes/imager/u/zoom/3983498/larry.jpg" title=""><img src="https://media1.fdncms.com/metrotimes/imager/u/story/3983498/larry.jpg" alt="larry.jpg" /></a>
            
            
              <ul>
                
                  
                  <li class="l0 credit">
                    
                      
                        
                      
                    
                  </li>
                
                  
                  <li class="l0 caption">
                    
                      
                    
                  </li>
                
              </ul>
            
          </div>
        
    
        
        
        
      </div><!-- .flipBook -->
    </div>
      </div>
    </div> <!-- end EmbeddedSidebar -->
  





<div id="StoryLayout" class="SpanningFeature ContentDefault ">

  

    

    













    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      
        
        
      
        
        
          
        
        
        
        

        
      
      
      
      
    
      <div id="storyBody" class="page1">
        
      
        

        
        
          <p>
<b>There I was</b>, bouncing around in the passenger seat of a borrowed pickup truck with a blindfold over my eyes. Mulenga Harangua was at the wheel driving us through a maze to his new secret spot. I was wearing the blindfold because he didn't want me to know exactly where it's at. The back of the truck was loaded down with wooden pallets we'd scrounged up around the west side, along with a few boards, bricks, and a few other things.
</p>
            
            
          
            
              

<p>
We hit a bump and I bounced over against Mulenga's shoulder.
</p>
            
            
              <div class="inlineComponent " id="">
                <div id="AdNativeInline" class="SpanningFeature AdNativeInline ">
  <!-- /43707298/DET_DesktopNative -->
          <div id="div-gpt-ad-det_desktopnative-2" style="" data-slot="/43707298/DET_DesktopNative" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_desktopnative-2');
                });
            </script>
          </div>
</div>
              </div>
            
          
            
              

<p>
"Well this ain't cuddling on the QLine, but it will do," I quipped.
</p>
            
            
          
            
              

<p>
"Cuddling on the QLine," sputtered Mulenga. "I had hopes for that in the beginning, they could have built a real train, a real building block for transit for this city. But it looks like they decided to just put in something for the tourists to get around and spend money. Cruising slowly along the curb so riders can view storefronts is pretty bald-faced capitalism. That's about making money in Midtown. It's not about creating a transit system for Detroit."
</p>
            
            
          
            
              

<p>
"Well, listen to you," I said. "The irony of it is that train lines are great development drivers when done right. But I don't think this was done right. They didn't need to lay tracks to put in a cute little trolley that lets you cruise the storefronts."
</p>
            
            
          
            
              

<p>
"Well there's no QLine over here," Mulenga stated proudly. "This here is the anti-Q &mdash; no train, not tracks, not even a road." 
</p>
            
            
          
            
              

<p>
"Why are you being so secretive?" I asked. 
</p>
            
            
          
            
              

<p>
"Because I'm digging in deeper underground," Mulenga said. "I can't have any leaks. Look at the president. Leak, leak, leak and he's going down. I'm not going down, my whereabouts are strictly on a need-to-know basis. Pretty much at this point only I need to know."
</p>
            
            
          
            
              

<p>
"Well I know where you are," I said.
</p>
            
            
          
            
              

<p>
"What?" Mulenga asked with a bit of alarm in his voice.
</p>
            
            
          
            
              

<p>
"Right next to you," I said in a lame punch line.
</p>
            
            
          
            
              

<p>
"And we have arrived," Mulenga said, turning the engine off. "You can remove your bandanna."
</p>
            
            
          
            
              

<p>
I pulled it off and looked around.  We were indeed surrounded on all sides with trees and bushes, with little to indicate that we were somewhere in Detroit &mdash; just a couple of poles with wire in the distance. There were a few lean-to looking things with barrels underneath, a small garden with young plants, and a handful of chickens scratching around. I also spotted a small fire pit and a few domestic items by one of the lean-tos.
</p>
            
            
          
            
              

<p>
Mulenga was out and pulling pallets off the back of the truck.
</p>
            
            
          
            
              

<p>
"So what are you going to do with this stuff?" I asked. 
</p>
            
            
          
            
              

<p>
"Chicken coops," he said. "I'm building chicken coops."
</p>
            
            
          
            
              

<p>
"I thought you were a free range chicken kind of guy," I teased.
</p>
            
            
          
            
              

<p>
"That's right, but some free range dogs came through here the other day and snacked on a few of my chickens," he said. "Now I need to put them safely away sometimes. I want to grow my flock."
</p>
            
            
          
            
              

<p>
"How many chickens are you planning on eating?" I wondered aloud.
</p>
            
            
          
            
              

<p>
"I don't plan on eating all that," Mulenga said. "I'm getting into the chicken business."
</p>
            
            
          
            
              

<p>
"What?"
</p>
            
            
          
            
              

<p>
"The chicken business," he repeated. "I'm getting in early. I think there is going to be big demand for fresh organic chicken pretty soon."
</p>
            
            
          
            
              

<p>
"Why is that?"
</p>
            
            
          
            
              

<p>
"Didn't you see that agreement the government just made to import chicken and chicken products from China?" he asked pointedly.
</p>
            
            
          
            
              

<p>
"No."
</p>
            
            
          
            
              

<p>
Mulenga started dragging pallets under a nearby tree. I did the same. 
</p>
            
            
          
            
              

<p>
"A few weeks ago I was listening to National Public Radio and I heard this story about the U.S-China trade deal," Mulenga explained. "Part of it is that we'll be importing cooked chicken products from China."
</p>
            
            
          
            
              

<p>
"Cooked chicken products?" I repeated, a little confused on Mulenga's point with his chickens. It's not like he was about to take on Chinese imports. A couple of his chickens started pecking around near my foot. 
</p>
            
            
          
            
              

<p>
"Well mostly I've been getting their eggs," Mulenga said. "But China is notorious for its food safety scandals. A couple of years ago a Shanghai company that supplied McDonald's and KFC was selling past-date meat that had been repackaged with new dates on it."
</p>
            
            
          
            
              

<p>
"And?"
</p>
            
            
          
            
              

<p>
"Sooner or later somebody is going to get sick from Chinese chicken," Mulenga said. "After that, people are going to be looking for fresh local chicken." He swept his arm toward the area I guess he was planning on keeping his chickens. "I will be ready when that market breaks open."
</p>
            
            
          
            
              

<p>
"So you're going to be the chicken king of Detroit?"
</p>
            
            
          
            
              

<p>
"Why not?" he tossed back at me. 
</p>
            
            
          
            
              

<p>
"So what's up with these lean-tos?" I asked in an effort to change the subject.
</p>
            
            
          
            
              

<p>
"These aren't lean-tos," Mulenga said. "These are to help me collect water in the rain barrels. " 
</p>
            
            
          
            
              

<p>
"Why so many?" I gestured toward the others nearby.
</p>
            
            
          
            
              

<p>
"That's another project," Mulenga explained. "See, I heard about this study predicting that in the next five years more than a third of Americans will not be able to afford their water. I plan to have plenty of water around for my garden and chickens, so why not sell a few low cost bottles on the side?"
</p>
            
            
          
            
              

<p>
"You want to sell water?"
</p>
            
            
          
            
              

<p>
"Well maybe I'll just trade it for stuff," Mulenga said. "You never know what people have that you can use. Rainwater may be the purest water available. It just falls from the sky. It might be cleaner than whatever comes out of your faucet. The bottom line is that I'm getting out front on this stuff. I got water. I got chicken. It's not a bad spot to be in. Plus, I can gather up the chicken droppings and use that for fertilizer."
</p>
            
            
          
            
              

<p>
"So now you're getting into the food industry," I said. "That is the next step for the urban agriculture scene, but most of those folks are growing vegetables. It doesn't look like you have much of that over here."
</p>
            
            
          
            
              

<p>
"I've got plenty of vegetables growing in my other plots," Mulenga said. "I have to keep my spaces diversified in case somebody decides to put a development in. That happened to me once. I had a great little squat on the west side with lots of space. One day the bulldozers showed up and started clearing things out. They put up a bunch of condos."
</p>
            
            
          
            
              

<p>
"Ouch!" I sympathized with him. I started to take a close look around. "So where are we? I need to get going."
</p>
            
            
          
            
              

<p>
"Can't tell you that," Mulenga said. "If you need to go you need to put that blindfold back on."
</p>
            
            
          
            
              

<p>
I pulled out the bandanna and wrapped it over my eyes. Mulenga took my arm and led me to the truck. It may have been a case of the blind leading the blindfolded.
</p>
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayout -->







    
    
    
    


















  


<div id="JumptoComments" class="SpanningFeature ContentDefault ">
  <a href="#Disqus">Jump to comments</a>
</div><!-- End JumptoComments -->










  <div id="StoryTags" class="SpanningFeature ContentDefault ">
    <p class="tags">Tags: <a href="/detroit/ArticleArchives?category=3317819" rel="tag">Stir It Up</a></p>          
  </div> <!-- end StoryTags -->






  
  
















  
  
    
  
  
  <div id="TallBar" class="SpanningFeature ContentDefault ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="standard"></fb:like></li> <li class="l0" style="width:12%;"><a href="https://twitter.com/share?url=http%3A//www.metrotimes.com/detroit/mulenga-and-the-chickens/Content%3Foid%3D3983499&text=Mulenga%20and%20the%20chickens" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0" style="width:12%;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" size="tall" count="true"></g:plusone></li> <li class="l0 last" style="width:12%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499" addthis:title="Mulenga and the chickens" addthis:description="" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51f9437a2abb7e86", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  



<div id="AdNativeEndofArticle" class="SpanningFeature ContentDefault ">
  <!-- /43707298/DET_DesktopNative -->
          <div id="div-gpt-ad-det_desktopnative-3" style="" data-slot="/43707298/DET_DesktopNative" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_desktopnative-3');
                });
            </script>
          </div>
</div>




  
  

  
  
  

  
    <div id="PreviousNextInCategory" class="SpanningFeature ContentDefault ">
      <div class="prevNext">
        
          
          

          <a href="http://www.metrotimes.com/detroit/stir-it-up-the-difficulty-in-defining-1967/Content?oid=3695648" class="prev" title="previous">&laquo;&nbsp;The difficulty in defining 1967</a>

          
          
        
        
      </div>
    </div>
  







  

  

  
  

  

  













  

  

  

    

    

    

    
      <div id="Disqus" class="SpanningFeature ContentDefault ">
        <div id="disqus_thread"></div>
        <script type="text/javascript">
        <!--
          var disqus_shortname = "metrotimes";
          var disqus_identifier = "metrotimes:3983499";
          var disqus_url = "http://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?oid=3983499";
          var disqus_title = "Mulenga and the chickens";
          (function() {
              var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
              dsq.src = "http://" + disqus_shortname + ".disqus.com/embed.js";
              (document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
          })();
        // -->
        </script>
        <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
      </div>
    

  

























  
  
      <div id="LatestInCategory" class="SpanningFeature ContentDefault ">
        <h3 class="lateststir_it_up"><span class="headingText">Latest in Stir It Up</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/stir-it-up-the-difficulty-in-defining-1967/Content?oid=3695648&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/3695647/18121406_270322850094595_5924547863752286122_o.jpg" alt="The difficulty in defining 1967" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/stir-it-up-the-difficulty-in-defining-1967/Content?oid=3695648&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">The difficulty in defining 1967</a>
    </h4>
    <div class="date">May 10, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/why-are-we-still-obsessed-with-1967/Content?oid=3498214&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/3498230/18121406_270322850094595_5924547863752286122_o.jpg" alt="Why are we still obsessed with 1967?" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/why-are-we-still-obsessed-with-1967/Content?oid=3498214&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">Why are we still obsessed with 1967?</a>
    </h4>
    <div class="date">Apr 26, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/stir-it-up-fitzgerald-neighborhood-calls-comeback-question/Content?oid=3304856&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/3304847/larry.jpg" alt="Stir It Up: Fitzgerald neighborhood calls  comeback question" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/stir-it-up-fitzgerald-neighborhood-calls-comeback-question/Content?oid=3304856&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">Stir It Up: Fitzgerald neighborhood calls  comeback question</a>
    </h4>
    <div class="date">Apr 12, 2017</div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="http://www.metrotimes.com/detroit/ArticleArchives?category=3317819&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    





  <div id="ArchiveLink" class="SpanningFeature ContentDefault ">
    <p class="moreArticles">
      
        <a href="http://www.metrotimes.com/detroit/ArticleArchives?category=3317819">More Stir It Up &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->









  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature ContentDefault Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature ContentDefault ">
            <h3><span class="headingText">More by Larry Gabriel</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/hopes-are-high-for-legal-pot-in-michigan/Content?oid=3883192&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/3883191/shutterstock_101771452.jpg" alt="Hopes are high for legal pot in Michigan" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/hopes-are-high-for-legal-pot-in-michigan/Content?oid=3883192&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Hopes are high for legal pot in Michigan</a>
    </h4>
    <div class="date">May 24, 2017</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/stir-it-up-the-difficulty-in-defining-1967/Content?oid=3695648&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/metrotimes/imager/u/bigsquare/3695647/18121406_270322850094595_5924547863752286122_o.jpg" alt="The difficulty in defining 1967" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/stir-it-up-the-difficulty-in-defining-1967/Content?oid=3695648&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">The difficulty in defining 1967</a>
    </h4>
    <div class="date">May 10, 2017</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/higher-ground-an-education-in-cultivation/Content?oid=3604585&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/3604584/larry.jpg" alt="An education in cultivation" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/higher-ground-an-education-in-cultivation/Content?oid=3604585&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">An education in cultivation</a>
    </h4>
    <div class="date">May  3, 2017</div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="http://www.metrotimes.com/detroit/ArticleArchives?author=2135311" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature ContentDefault ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/stir-it-up-no-one-is-to-blame-for-flint-but-snyder/Content?oid=2387976&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/2387975/stiritup1-1-e82b9e73b5060299.jpg" alt="Stir it up: No one is to blame for Flint but Snyder" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/stir-it-up-no-one-is-to-blame-for-flint-but-snyder/Content?oid=2387976&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">Stir it up: No one is to blame for Flint but Snyder</a>
    </h4>
    <div class="date">Dec 30, 2015</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/detroit/why-are-we-still-obsessed-with-1967/Content?oid=3498214&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/3498230/18121406_270322850094595_5924547863752286122_o.jpg" alt="Why are we still obsessed with 1967?" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/why-are-we-still-obsessed-with-1967/Content?oid=3498214&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">Why are we still obsessed with 1967?</a>
    </h4>
    <div class="date">Apr 26, 2017</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      <a href="http://www.metrotimes.com/news-hits/archives/2016/01/11/esquire-its-time-for-snyder-to-go?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/metrotimes/imager/u/bigsquare/2389742/ricksnyder.jpg" alt="&lt;i&gt;Esquire&lt;/i&gt;: It&#39;s time for Snyder to go" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.metrotimes.com/news-hits/archives/2016/01/11/esquire-its-time-for-snyder-to-go?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=PeopleWhoLiked"><i>Esquire</i>: It's time for Snyder to go</a>
    </h4>
    <div class="date">Jan 11, 2016</div>
  </li>
      
      
    
          </ul>
        </div>
      
               

    

    





      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        









<div id="TabbedPopularity" class="SpanningIsland ContentDefault ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
    <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    
        <ol class="moduleList">
      
      
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/news-hits/archives/2017/05/26/anti-circumcision-protestors-demand-genital-mutilation-protections-for-boys?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Anti-circumcision protestors demand genital mutilation protections for boys <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/as-belle-isles-grand-prix-hits-a-crossroads-gearheads-and-park-enthusiasts-tussle-for-its-future/Content?oid=3982199&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">As Belle Isle’s Grand Prix hits a crossroads, gearheads and parkgoers tussle for its future <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/horoscopes-may-31-june-6/Content?oid=3982876&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Horoscopes (May 31-June 6) <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/governor-abdul/Content?oid=3983331&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Governor Abdul? <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/savage-love-looking/Content?oid=3983495&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Savage Love: Looking <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>  

  

  <div class="popularityBody" style="display:none">
    

    
    <div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://disqus.com/forums/metrotimes/popular_threads_widget.js?num_items=5&hide_avatars=1&avatar_size=32&excerpt_length=200"></script></div>
  </div>
  
  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="http://www.metrotimes.com/detroit/IssueArchives?issue=3982066&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/3982066/0a1a/34-Cover-BelleIsle__1_.jpg" alt="Issue Cover" />
          
        </a>
        <p>May 31- 6, 2017</p>
      </div>
    
    
        <ol class="moduleList">
      
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/a-ground-level-look-at-one-of-detroits-most-progressive-housing-initiatives-yet-and-why-residents-say-it-still-comes-up-short/Content?oid=3983329&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">A ground-level look at one of Detroit’s most progressive housing initiatives yet <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/governor-abdul/Content?oid=3983331&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Governor Abdul? <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/sheeba-in-hamtramck-is-culturally-advantaged/Content?oid=3983334&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Get cultured at Hamtramck's Sheeba <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/cinetopia-film-festival-returns-with-an-international-marathon-of-top-notch-flicks/Content?oid=3982868&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Cinetopia Film Festival returns with an international marathon of top-notch flicks <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/rejoice-for-there-is-a-new-soft-location-album/Content?oid=3983120&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Rejoice, for there is a new Soft Location album <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/savage-love-looking/Content?oid=3983495&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Savage Love: Looking <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="http://www.metrotimes.com/detroit/horoscopes-may-31-june-6/Content?oid=3982876&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Horoscopes (May 31-June 6) <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
    // 
    jQuery('div.tabs div#tabLatest').click();
});
//-->
</script>
<!-- End #TabbedPopularity -->










<div id="SearchRightCol" class="SpanningIsland ContentDefault  search-wrap">
    
    <form class="prepTextForm" id="searchbox_017793458706336421686:uqt4fqpywfe" action="http://www.metrotimes.com/detroit/Search">
      <input type="hidden" name="cx" value="017793458706336421686:uqt4fqpywfe" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="http://www.metrotimes.com/detroit/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="http://www.metrotimes.com/detroit/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="http://www.metrotimes.com/detroit/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="http://www.metrotimes.com/detroit/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            window.location = newLocation + "?keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->
<div id="AdMediumRectangle1300x250" class="SpanningIsland ContentDefault ">
  <!-- /43707298/DET_300x250 -->
          <div id="div-gpt-ad-det_300x250-1" style="" data-slot="/43707298/DET_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_300x250-1');
                });
            </script>
          </div>
</div><div id="ORATVAANPartnerWidget" class="SpanningIsland ContentDefault ">
  <iframe width="300" height="169" src="https://www.ora.tv/embed/partner/metrotimes/playlist/179/v/1"frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>
</div>









































<div id="TabbedCalendar" class="SpanningIsland ContentDefault ">
  <h2>Best Things to Do In Detroit</h2>

  <div class="tabs">
    <div id="tabEvents" class="tab"><a href="#">Events</a></div>
    <div id="tabMusic"  class="tab"><a href="#">Music</a></div>
    <div id="tabMovies" class="tab"><a href="#">Movies</a></div>
    <div id="tabArts"   class="tab"><a href="#">Arts</a></div>
    <div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/beginner-tai-chi-chuan-classes/Event?oid=2235085&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Beginner T'ai Chi Ch'uan Classes <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/business-in-the-black-premier/Event?oid=3883088&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Business in the Black premier <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/premier-for-business-in-the-black/Event?oid=3602889&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Premier for Business in the Black <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/we-wove-a-net/Event?oid=3901333&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        We Wove A Net <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/this-is-hunger-free-national-exhibit-a-must-see-experience/Event?oid=3534788&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        “This Is Hunger” Free National Exhibit: A Must-See Experience <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167738&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167738&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167738&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/dr-octagon/Event?oid=3883130&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Dr. Octagon <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/why-do-fools-fall-in-love/Event?oid=3980095&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Why Do Fools Fall in Love <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/the-moonrise-fundraiser/Event?oid=3811855&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The Moonrise Fundraiser <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/the-arks-open-stage/Event?oid=3343925&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The Ark's Open Stage <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/dr-octagon/Event?oid=3732588&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Dr. Octagon <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>  

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167732&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167732&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167732&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/business-in-the-black-premier/Event?oid=3883088&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Business in the Black premier <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/premier-for-business-in-the-black/Event?oid=3602889&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Premier for Business in the Black <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/we-wove-a-net/Event?oid=3901333&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        We Wove A Net <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/business-in-the-black-documentary/Event?oid=3719701&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Business in the Black documentary <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/cinetopia-international-film-festival/Event?oid=3168585&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Cinetopia international Film Festival <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167727&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167727&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="http://www.metrotimes.com/detroit/EventSearch?eventSection=2167727&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/blooms-bugs-beasts/Event?oid=3817901&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        BLOOMS, BUGS, BEASTS <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/drawn-to-detroit-scarab-club-sketch-session-artists/Event?oid=3825208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        DRAWN TO DETROIT: Scarab Club Sketch Session Artists <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/charles-mcgee-exhibit-opening/Event?oid=3979470&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Charles McGee exhibit opening <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/art-the-max-ii/Event?oid=3801772&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Art @ The Max II <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/cinetopia-international-film-festival/Event?oid=3168585&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Cinetopia international Film Festival <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/wintergarden-tavern/Location?oid=2133549&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Wintergarden Tavern <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/rock-on-3rd/Location?oid=2131438&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Rock on 3rd <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.metrotimes.com/detroit/227-bistro/Location?oid=2125038&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        227 Bistro <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
    <form name="diningSearchForm" method="get" action="http://www.metrotimes.com/detroit/LocationSearch">
      <input type="hidden" name="locationSection" value="2124727" />
      <input type="hidden" name="guide" value="2124367" />
      <select name="locationCategory">
        <option value="">-All Categories-</option>
        
          <option value="2124811">African</option>
        
          <option value="2124812">American</option>
        
          <option value="2124813">Asian</option>
        
          <option value="2124814">Barbeque</option>
        
          <option value="2124815">Belgian</option>
        
          <option value="2124816">Bistro</option>
        
          <option value="2124817">Brazilian</option>
        
          <option value="2124818">Breakfast</option>
        
          <option value="2124819">Burgers</option>
        
          <option value="2124820">Café</option>
        
          <option value="2124821">Cajun-Creole</option>
        
          <option value="2124822">Caribbean</option>
        
          <option value="2124823">Central American</option>
        
          <option value="2124824">Chinese</option>
        
          <option value="2124768">Coffee House</option>
        
          <option value="2124825">Continental</option>
        
          <option value="2124826">Cuban</option>
        
          <option value="2124827">Deli</option>
        
          <option value="2124828">Diner</option>
        
          <option value="2124829">Eclectic</option>
        
          <option value="2124830">Ethiopian</option>
        
          <option value="2124831">European</option>
        
          <option value="2124832">Filipino</option>
        
          <option value="2124833">French</option>
        
          <option value="2124834">German</option>
        
          <option value="2124835">Greek</option>
        
          <option value="2124836">Hungarian</option>
        
          <option value="2124837">Indian</option>
        
          <option value="2124838">Irish</option>
        
          <option value="2124839">Italian</option>
        
          <option value="2124840">Japanese</option>
        
          <option value="2124841">Korean</option>
        
          <option value="2124842">Mediterranean</option>
        
          <option value="2124843">Mexican</option>
        
          <option value="2124844">Middle East</option>
        
          <option value="2124845">Pizza</option>
        
          <option value="2124846">Polish</option>
        
          <option value="2124847">Russian</option>
        
          <option value="2124848">Salads</option>
        
          <option value="2124849">Seafood</option>
        
          <option value="2124850">Soul Food</option>
        
          <option value="2124851">Soup</option>
        
          <option value="2124852">Steak</option>
        
          <option value="2124853">Sushi</option>
        
          <option value="2124854">Sweets</option>
        
          <option value="2124855">Tavern Fare</option>
        
          <option value="2124856">Thai</option>
        
          <option value="2124857">Vegetarian Menu</option>
        
          <option value="2124858">Vietnamese</option>
        
      </select>
      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="2351702" >BRIGHTON</option>
        
        <option value="2351704" >&nbsp;&nbsp;Brighton</option>
      
        
          <option value="2367405" >CANADA</option>
        
        <option value="2367406" >&nbsp;&nbsp;Canada</option>
      
        
          <option value="2257133" >LANSING</option>
        
        <option value="2257134" >&nbsp;&nbsp;East Lansing</option>
      
        
          <option value="2313144" >FARMINGTON</option>
        
        <option value="2313146" >&nbsp;&nbsp;Farmington Hills</option>
      
        
          <option value="2449071" >FLINT</option>
        
        <option value="2449072" >&nbsp;&nbsp;Flint</option>
      
        
          <option value="2373247" >MACOMB</option>
        
        <option value="2373248" >&nbsp;&nbsp;Fraser</option>
      
        
          <option value="2313144" >FARMINGTON</option>
        
        <option value="2313145" >&nbsp;&nbsp;Great Farmington Area</option>
      
        
          <option value="2449071" >FLINT</option>
        
        <option value="2449073" >&nbsp;&nbsp;Greater Flint Area</option>
      
        
          <option value="2384610" >LIVONIA</option>
        
        <option value="2384611" >&nbsp;&nbsp;Livonia</option>
      
        
          <option value="2373247" >MACOMB</option>
        
        <option value="2373249" >&nbsp;&nbsp;Macomb</option>
      
        
          <option value="2313142" >NOVI</option>
        
        <option value="2313143" >&nbsp;&nbsp;Novi</option>
      
        
          <option value="2373247" >MACOMB</option>
        
        <option value="2373903" >&nbsp;&nbsp;Romeo</option>
      
        
          <option value="2361677" >UP NORTH</option>
        
        <option value="2361678" >&nbsp;&nbsp;Up North</option>
      
        
          <option value="2124962" >DETROIT</option>
        
        <option value="2124918" >&nbsp;&nbsp;Downtown Detroit</option>
      
        
          <option value="2351702" >BRIGHTON</option>
        
        <option value="2351705" >&nbsp;&nbsp;Greater Brighton Area</option>
      
        
          <option value="2124962" >DETROIT</option>
        
        <option value="2124919" >&nbsp;&nbsp;East English Village</option>
      
        
        <option value="2124920" >&nbsp;&nbsp;Greektown</option>
      
        
        <option value="2124922" >&nbsp;&nbsp;Mexicantown</option>
      
        
        <option value="2124923" >&nbsp;&nbsp;Midtown</option>
      
        
        <option value="2124924" >&nbsp;&nbsp;New Center</option>
      
        
        <option value="2124925" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="2124926" >&nbsp;&nbsp;The Hill</option>
      
        
        <option value="2124927" >&nbsp;&nbsp;University District</option>
      
        
        <option value="2124928" >&nbsp;&nbsp;Village Area</option>
      
        
        <option value="2124929" >&nbsp;&nbsp;Wayne State University</option>
      
        
        <option value="2124930" >&nbsp;&nbsp;West Village</option>
      
        
        <option value="2124931" >&nbsp;&nbsp;Corktown</option>
      
        
        <option value="2124932" >&nbsp;&nbsp;Eastern Market</option>
      
        
        <option value="2124938" >&nbsp;&nbsp;Downriver</option>
      
        
        <option value="2124939" >&nbsp;&nbsp;Cass Corridor</option>
      
        
        <option value="2124945" >&nbsp;&nbsp;Woodbridge</option>
      
        
        <option value="2125052" >&nbsp;&nbsp;Greater Detroit Area</option>
      
        
          <option value="2124967" >HAMTRAMCK</option>
        
        <option value="2124921" >&nbsp;&nbsp;Hamtramck</option>
      
        
        <option value="2125057" >&nbsp;&nbsp;Greater Hamtramck Area</option>
      
        
          <option value="2124965" >DEARBORN</option>
        
        <option value="2124942" >&nbsp;&nbsp;Downtown Dearborn</option>
      
        
        <option value="2124943" >&nbsp;&nbsp;East Downtown Dearborn</option>
      
        
        <option value="2125055" >&nbsp;&nbsp;Greater Dearborn Area</option>
      
        
          <option value="2124966" >FERNDALE</option>
        
        <option value="2124933" >&nbsp;&nbsp;Downtown Ferndale</option>
      
        
        <option value="2125056" >&nbsp;&nbsp;Greater Ferndale Area</option>
      
        
          <option value="2124974" >ST. CLAIR SHORES</option>
        
        <option value="2124937" >&nbsp;&nbsp;Downtown St. Clair Shores</option>
      
        
        <option value="2125064" >&nbsp;&nbsp;Greater St. Clair Shores Area</option>
      
        
          <option value="2124973" >ROYAL OAK</option>
        
        <option value="2124940" >&nbsp;&nbsp;Downtown Royal Oak</option>
      
        
        <option value="2125063" >&nbsp;&nbsp;Greater Royal Oak Area</option>
      
        
          <option value="2124968" >MOUNT CLEMENS</option>
        
        <option value="2124936" >&nbsp;&nbsp;Downtown Mount Clemens</option>
      
        
          <option value="2124964" >BIRMINGHAM</option>
        
        <option value="2124946" >&nbsp;&nbsp;Downtown Birmingham</option>
      
        
        <option value="2125054" >&nbsp;&nbsp;Greater Birmingham Area</option>
      
        
          <option value="2124968" >MOUNT CLEMENS</option>
        
        <option value="2125058" >&nbsp;&nbsp;Greater Mount Clemens Area</option>
      
        
          <option value="2124972" >ROCHESTER</option>
        
        <option value="2124948" >&nbsp;&nbsp;Downtown Rochester</option>
      
        
        <option value="2125062" >&nbsp;&nbsp;Greater Rochester Area</option>
      
        
          <option value="2124971" >PONTIAC</option>
        
        <option value="2124935" >&nbsp;&nbsp;Downtown Pontiac</option>
      
        
        <option value="2125061" >&nbsp;&nbsp;Greater Pontiac Area</option>
      
        
          <option value="2124970" >PLYMOUTH</option>
        
        <option value="2124949" >&nbsp;&nbsp;Downtown Plymouth</option>
      
        
        <option value="2125060" >&nbsp;&nbsp;Greater Plymouth Area</option>
      
        
          <option value="2124969" >NORTHVILLE</option>
        
        <option value="2124947" >&nbsp;&nbsp;Downtown Northville</option>
      
        
        <option value="2125059" >&nbsp;&nbsp;Greater Northville Area</option>
      
        
          <option value="2124975" >YPSILANTI</option>
        
        <option value="2124917" >&nbsp;&nbsp;Depot Town</option>
      
        
        <option value="2124941" >&nbsp;&nbsp;Downtown Ypsilanti</option>
      
        
        <option value="2125065" >&nbsp;&nbsp;Greater Ypsilanti Area</option>
      
        
          <option value="2124963" >ANN ARBOR</option>
        
        <option value="2124934" >&nbsp;&nbsp;Downtown Ann Arbor</option>
      
        
        <option value="2124944" >&nbsp;&nbsp;Kerrytown</option>
      
        
        <option value="2125053" >&nbsp;&nbsp;Greater Ann Arbor Area</option>
      
        
          <option value="2390277" >DOWNRIVER</option>
        
        <option value="2390278" >&nbsp;&nbsp;Wyandotte</option>
      
        
          <option value="2336440" >SAGINAW</option>
        
        <option value="2336444" >&nbsp;&nbsp;Greater Saginaw Area</option>
      
    
  </select>
      <div class="searchBox">
        <input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
        <input type="submit" value="go" />
      </div>
    </form>
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 0
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>

  <div id="PromoGraphicLinkCustom" class="SpanningIsland ContentDefault ">
    <ul class="componentBody">
      
        <li class="left">
          
            <a href="http://mtbestof2017.com/"><img src="/binary/2961/BOD17Party_160X160.jpg" /></a>
          
        </li>    
      
        <li class="right">
          
            <img src="/binary/643e/AnnMann_150x150.gif" />
          
        </li>    
      
    </ul>
    
  </div>
<div id="AdMediumRectangle2300x250" class="SpanningIsland ContentDefault ">
  <!-- /43707298/DET_300x250 -->
          <div id="div-gpt-ad-det_300x250-2" style="" data-slot="/43707298/DET_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_300x250-2');
                });
            </script>
          </div>
</div>


  <div id="PhotoSlideshows" class="SpanningIsland ContentDefault ">
    <h2><a href="http://photos.metrotimes.com/" target="_blank">Newest Slideshows</a></h2>
    <iframe src="https://www.metrotimes.com/detroit/mulenga-and-the-chickens/Content?ajaxComponent=PhotoSlideshows&iframeRendered=yes" 
            height="419" 
            width="364"
            scrolling="no" 
            frameborder="0"></iframe>
  </div>
  <!-- End #PhotoSlideshows -->





  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  






  <div id="NewsletterSignup" class="SpanningIsland ContentDefault ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <!-- BEGIN: Constant Contact Email List Form Button -->
<h3>Never miss a beat</h3>
<a href="/detroit/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color: rgb(217, 31, 52);font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
<!-- END: Constant Contact Email List Form Button -->
    </div>
  </div>
  














    <div id="SpecialIssues" class="SpanningIsland ContentDefault ">
      <h2><a href="http://www.metrotimes.com/detroit/special-issues/Section?oid=2135208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/detroit/welcome-to-the-best-of-detroit-2017/BestOf?oid=3497208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/metrotimes/imager/u/original/3499154/dmt_bod2017_cover_v4-copy.jpg);">
      <span class="grayRedBox">Best of Detroit</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/flavor/Category?oid=2477494&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/metrotimes/imager/u/original/2477571/flavor.jpg);">
      <span class="grayRedBox">FLAVOR</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/detroit/IssueArchives?issue=3036865&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/metrotimes/imager/u/original/3038895/anman17.jpg);">
      <span class="grayRedBox">Annual Manual</span>
    </a>
  </div>
  

      <a href="http://www.metrotimes.com/detroit/special-issues/Section?oid=2135208&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  
<div id="AdMediumRectangle3300x250" class="SpanningIsland ContentDefault ">
  <!-- /43707298/DET_300x250 -->
          <div id="div-gpt-ad-det_300x250-3" style="" data-slot="/43707298/DET_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_300x250-3');
                });
            </script>
          </div>
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter ContentDefault ">
  <div class="footerCustomInfo">
    <h2>Metro Times</h2>
    <p>1200 Woodward Heights Blvd</p>
    <p>Ferndale, MI 48220</p>
    <p>Main: (313) 961-4060</p>
    <p>Advertising: (313) 961-4060</p>
    <p>Classified: (313) 961-4060</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="http://www.metrotimes.com/detroit/StaffDirectory/Page">Contact MT</a></li>
        <li><a target="_top" href="http://www.metrotimes.com/detroit/Advertise/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
        <li><a target="_top" href="http://www.metrotimes.com/detroit/Careers/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2017 Detroit Metro Times.</p>
    </div>
    <div class="footerRssLink">
      <a href="http://www.metrotimes.com/detroit/Syndication" class="RSSLink">RSS Feeds</a>
    </div>    

    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="http://posting.metrotimes.com/detroit/MyProfile">View Profile</a> / </li>
          <li><a href="http://posting.metrotimes.com/detroit/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="http://www.metrotimes.com/detroit/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdFooter728x90" class="GlobalFooter ContentDefault ">
  <!-- /43707298/DET_728x90 -->
          <div id="div-gpt-ad-det_728x90-2" style="" data-slot="/43707298/DET_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_728x90-2');
                });
            </script>
          </div>
</div>


















<div id="FooterNavigation" class="GlobalFooter ContentDefault ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/news-and-views/Section?oid=2135207" 
               target="_">
              News
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/news-and-views/Section?oid=2135207" >News Home</a></li>
          
            <li><a href="/Blogs/archives/news-blog/" >News Blog</a></li>
          
            <li><a href="/detroit/savage-love/Category?oid=2162739" >Savage Love</a></li>
          
            <li><a href="/detroit/feedback/Category?oid=2162740" >Letters</a></li>
          
            <li><a href="/detroit/IssueArchives?issue=this%20week" target="_blank">e-Edition</a></li>
          
            <li><a href="/detroit/joblistings/Page" >Local Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/blogs/Blogs/" 
               target="_">
              Blogs
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/blogs/Blogs/" >Blog Home</a></li>
          
            <li><a href="/Blogs/archives/news-blog/" >News Blog</a></li>
          
            <li><a href="/Blogs/archives/music-blog/" >Music Blog</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/music/Section?oid=2124980" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/music/Section?oid=2124980" >Music Home</a></li>
          
            <li><a href="/Blogs/archives/music-blog/" >Music Blog</a></li>
          
            <li><a href="/detroit/EventSearch?eventSection=2167738" >Search Music Events</a></li>
          
            <li><a href="/detroit/Events/AddEvent" >Add Music Events</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/arts-and-culture/Section?oid=2124977" 
               target="_">
              Arts and Culture
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/arts-and-culture/Section?oid=2124977" >Arts and Culture Home</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/EventSearch" 
               target="_">
              Events
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/EventSearch" >Events Home</a></li>
          
            <li><a href="/detroit/EventSearch" >Search Calendar</a></li>
          
            <li><a href="/detroit/Events/AddEvent" >Add Calendar Event</a></li>
          
            <li><a href="/detroit/FreeStuff" >Free Stuff</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/food-and-drink/Section?oid=2124982" 
               target="_">
              Dining
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/food-and-drink/Section?oid=2124982" >Dining Home</a></li>
          
            <li><a href="/detroit/LocationSearch?locationSection=2124727&guide=2124367" >Find a Restaurant</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/ArticleArchives" 
               target="_">
              Archives
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/ArticleArchives" >Search Archives</a></li>
          
            <li><a href="/detroit/ArticleArchives" >Search Authors</a></li>
          
            <li><a href="/detroit/IssueArchives" >Search Issues</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/welcome-to-the-best-of-detroit-2017/BestOf?oid=3497208" 
               target="_">
              Best of Detroit
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/BestOf" >Best of Detroit Home</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/detroit/special-issues/Section?oid=2135208" 
               target="_">
              Special Issues
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="http://www.metrotimes.com/detroit/detroit-lions-season-preview/Category?oid=2243480">Detroit Lions Season Preview</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/fall-arts-guide/Category?oid=2249726">Fall Arts Guide</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/sloshed/Category?oid=2135227">Sloshed</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/the-halloween-issue/Category?oid=2261605">The Halloween Issue</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/gift-guide/Category?oid=2270184">Gift Guide</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/flavor/Category?oid=2477494">Flavor</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/lust-issue/Category?oid=2135225">Lust Issue</a></li>
  
    <li><a href="http://www.metrotimes.com/detroit/annual-manual/Category?oid=2135220">Annual Manual</a></li>

          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>Classified</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/joblistings/Page" >Local Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://metrotimes.com/facebook" target="_blank">Facebook</a></li>
          
            <li><a href="http://www.twitter.com/metrotimes" target="_blank">Twitter</a></li>
          
            <li><a href="http://instagram.com/metrotimes" target="_blank">Instagram</a></li>
          
            <li><a href="https://plus.google.com/114596149904731441663/about" target="_blank">Google Plus</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>About Metro Times</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/detroit/StaffDirectory/Page" >Contact Us</a></li>
          
            <li><a href="/detroit/Advertise/Page" >Advertise</a></li>
          
            <li><a href="/detroit/Policies/Page" >Policies</a></li>
          
            <li><a href="/detroit/PrivacyStatement/Page" >Privacy Statement</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigation -->
<div id="footerCopyright">
  <p>
   &copy; 2017
   Detroit Metro Times 
   <br><br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div>
    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdBackground" class="Closer ContentDefault ">
  <!-- /43707298/DET_Reskin -->
          <div id="div-gpt-ad-det_reskin" style="" data-slot="/43707298/DET_Reskin" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-det_reskin');
                });
            </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  

